aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/300-ip_tiny.patch
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2017-03-20 21:53:46 +0000
committerFelix Fietkau <nbd@nbd.name>2017-05-30 14:00:31 +0200
commita4198f8c8d2c6bc57660d21f7ce97f3c0d19b736 (patch)
tree42388d2271d7f89e30b8685a79a60e3d53906701 /package/network/utils/iproute2/patches/300-ip_tiny.patch
parent6af0facb4e0a99beae449d635ff2c5c9ce3a557c (diff)
downloadupstream-a4198f8c8d2c6bc57660d21f7ce97f3c0d19b736.tar.gz
upstream-a4198f8c8d2c6bc57660d21f7ce97f3c0d19b736.tar.bz2
upstream-a4198f8c8d2c6bc57660d21f7ce97f3c0d19b736.zip
iproute2: bump to 4.11
Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/network/utils/iproute2/patches/300-ip_tiny.patch')
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index 290adbe5f5..e1b1da4d20 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -17,6 +17,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
+@@ -19,6 +19,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
CFLAGS += -DHAVE_SETNS
endif
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -44,7 +51,7 @@ else
+@@ -48,7 +55,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -25,7 +25,7 @@
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
--- a/ip/ip.c
+++ b/ip/ip.c
-@@ -73,30 +73,42 @@ static const struct cmd {
+@@ -74,32 +74,44 @@ static const struct cmd {
int (*func)(int argc, char **argv);
} cmds[] = {
{ "address", do_ipaddr },
@@ -46,6 +46,8 @@
{ "l2tp", do_ipl2tp },
{ "fou", do_ipfou },
+#endif
+ { "ila", do_ipila },
+ { "macsec", do_ipmacsec },
{ "tunnel", do_iptunnel },
{ "tunl", do_iptunnel },
+#ifndef IPROUTE2_TINY
@@ -65,12 +67,12 @@
+#ifndef IPROUTE2_TINY
{ "netconf", do_ipnetconf },
+#endif
+ { "vrf", do_ipvrf},
{ "help", do_help },
{ 0 }
- };
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -710,6 +710,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -777,6 +777,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
@@ -78,7 +80,7 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -718,6 +719,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -786,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}