aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/300-ip_tiny.patch
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-05-01 22:00:25 +0200
committerJohn Crispin <john@phrozen.org>2018-05-02 09:18:26 +0200
commit2f1e329d7a212f645a42046f2b860573b1a1281a (patch)
tree556bc3e64f15dee2de25c6688db51faf61d7a24f /package/network/utils/iproute2/patches/300-ip_tiny.patch
parent3aa28f4833bb9678fd92878ec388645071c4e0f3 (diff)
downloadupstream-2f1e329d7a212f645a42046f2b860573b1a1281a.tar.gz
upstream-2f1e329d7a212f645a42046f2b860573b1a1281a.tar.bz2
upstream-2f1e329d7a212f645a42046f2b860573b1a1281a.zip
iproute2: update to 4.16
Update to latest version of iproute2, refresh patches. See https://lkml.org/lkml/2018/4/2/349 for a full overview of the changes in 4.16. Build and tested on AR7xxx against musl Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/iproute2/patches/300-ip_tiny.patch')
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index d06e91e372..d8f39d3910 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -89,7 +89,7 @@
{ "help", do_help },
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -885,6 +885,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -983,6 +983,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
@@ -97,14 +97,14 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -894,6 +895,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -992,6 +993,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
+#endif
case AF_PACKET:
return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
- default:
+ case AF_BRIDGE:
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk