aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
diff options
context:
space:
mode:
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>2019-07-03 13:32:07 +0800
committerHans Dedecker <dedeckeh@gmail.com>2019-07-04 21:40:12 +0200
commit917eeaf26bca5342817419d0c360301896932476 (patch)
treefd411311eee7b4b08746fc930706289193cea197 /package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
parent92f83abc5e0f7bacd0392ce0c1cddcfb358f0d03 (diff)
downloadupstream-917eeaf26bca5342817419d0c360301896932476.tar.gz
upstream-917eeaf26bca5342817419d0c360301896932476.tar.bz2
upstream-917eeaf26bca5342817419d0c360301896932476.zip
iproute2: update to 5.1.0
Update iproute2 to 5.1.0 Remove upstream patch 010-cake-fwmark.patch Backport a patch to fix struct sysinfo redefinition error Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch')
-rw-r--r--package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
index 64ab135589..10123a78c3 100644
--- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
+++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
@@ -1,6 +1,6 @@
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -107,7 +107,7 @@ LDLIBS += -L. -lm
+@@ -108,7 +108,7 @@ LDLIBS += -L. -lm
ifeq ($(SHARED_LIBS),y)
LDLIBS += -ldl
@@ -9,7 +9,7 @@
endif
TCLIB := tc_core.o
-@@ -137,7 +137,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -138,7 +138,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
all: tc $(TCSO)
tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@
libtc.a: $(TCLIB)
$(QUIET_AR)$(AR) rcs $@ $^
-@@ -159,6 +159,7 @@ install: all
+@@ -160,6 +160,7 @@ install: all
clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
rm -f emp_ematch.yacc.*
@@ -26,7 +26,7 @@
q_atm.so: q_atm.c
$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -198,4 +199,15 @@ static-syms.h: $(wildcard *.c)
+@@ -199,4 +200,15 @@ static-syms.h: $(wildcard *.c)
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
done > $@