aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2019-02-19 15:12:53 +0100
committerHans Dedecker <dedeckeh@gmail.com>2019-02-19 15:22:28 +0100
commit566bfa417e0e210a47b5481fa2001de0b47a9914 (patch)
tree372887e7fa1667515a33158407c80c2247a268c6 /package/network/utils/iproute2/Makefile
parent96060b3018763268324bfdbc151b42a9b2adbe42 (diff)
downloadupstream-566bfa417e0e210a47b5481fa2001de0b47a9914.tar.gz
upstream-566bfa417e0e210a47b5481fa2001de0b47a9914.tar.bz2
upstream-566bfa417e0e210a47b5481fa2001de0b47a9914.zip
Revert "iproute2: tc: enable and fix support for using .so plugins"
This reverts commit fc80ef3613465e60257a5ddf0674debe45b09180 as it breaks the installation of the iproute2 utilities ip-bridge, ss, nstat, devlink and rdma for the ip-full variant Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 6e20e34dd8..a9bcfd40a0 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -106,7 +106,6 @@ endif
ifeq ($(BUILD_VARIANT),tc)
HAVE_ELF:=y
- SHARED_LIBS:=y
endif
ifdef CONFIG_PACKAGE_devlink
@@ -128,7 +127,7 @@ TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libnl-tiny
MAKE_FLAGS += \
KERNEL_INCLUDE="$(LINUX_DIR)/user_headers/include" \
- SHARED_LIBS=$(SHARED_LIBS) \
+ SHARED_LIBS="" \
IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
HAVE_ELF=$(HAVE_ELF) \
HAVE_MNL=$(HAVE_MNL) \
@@ -165,10 +164,6 @@ define Package/tc/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_BIN) ./files/15-teql $(1)/etc/hotplug.d/iface/
-ifeq ($(SHARED_LIBS),y)
- $(INSTALL_DIR) $(1)/usr/lib/tc
- $(CP) $(PKG_BUILD_DIR)/tc/*.so $(1)/usr/lib/tc
-endif
endef
# ensure other packages are only saved during 'tiny' builds.