aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-27 05:43:03 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-04-10 14:22:28 +0200
commit40143873d654108503a90ad9d52ea9e74d6e6ffd (patch)
treeaccab3fbb9cd448711bba27d0be1e9182b6beb9c /package/network/utils/iproute2/Makefile
parent879cbd9e97bb4cf1c87f907946c6be0e8d46a1fd (diff)
downloadupstream-40143873d654108503a90ad9d52ea9e74d6e6ffd.tar.gz
upstream-40143873d654108503a90ad9d52ea9e74d6e6ffd.tar.bz2
upstream-40143873d654108503a90ad9d52ea9e74d6e6ffd.zip
iproute2: fix libbpf detection with NLS enabled
Upstream iproute2 detects libbpf using a one-line $CC test-compile, which normally ignores LDFLAGS. With NLS enabled however, LDFLAGS includes an "rpath-link" linker option needed to resolve libintl.so. Its absence causes both the compile and libbpf detection to fail: ld: warning: libintl.so.8, needed by libbpf.so, not found (try using -rpath or -rpath-link) ld: libelf.so.1: undefined reference to `libintl_dgettext' collect2: error: ld returned 1 exit status Fix this by directly including $LDFLAGS in the test-compile command. Reported-by: Ian Cooper <iancooper@hotmail.com> Signed-off-by: Tony Ambardar <itugrok@yahoo.com> (cherry picked from commit aab3a04ce87c27996b7ce9ea306db8c6eed86941)
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index b1a137c18f..d7a7b3ed0f 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=5.11.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2