aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-12-13 11:48:55 -0800
committerHans Dedecker <dedeckeh@gmail.com>2019-03-14 22:54:59 +0100
commit0b57a2165a4c9c0f5f5032d7924ef65539571b1f (patch)
treeb70b39a5811059f47498879c394a38abda23074b /package/network/utils/iproute2/Makefile
parentf61359e16ef911a8fc01e7028942d9cad0bd8a96 (diff)
downloadupstream-0b57a2165a4c9c0f5f5032d7924ef65539571b1f.tar.gz
upstream-0b57a2165a4c9c0f5f5032d7924ef65539571b1f.tar.bz2
upstream-0b57a2165a4c9c0f5f5032d7924ef65539571b1f.zip
iproute2: tc: enable and fix support for using .so plugins
This enables using the tc module m_xt.so, which uses the act_ipt kernel module to allow tc actions based on iptables targets. e.g. tc filter add dev eth0 parent 1: prio 10 protocol ip \ u32 match u32 0 0 action xt -j DSCP --set-dscp-class BE Make the SHARED_LIBS parameter configurable and based on tc package selection. Fix a problem using the tc m_xt.so plugin as also described in https://bugs.debian.org/868059: Sync include/xtables.h from iptables to make sure the right offset is used when accessing structure members defined in libxtables. One could get “Extension does not know id …” otherwise. (See also: #868059) Patch to sync the included xtables.h with system iptables 1.6.x. This continues to work with iptables 1.8.2. Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 59b25404b9..f48636e996 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -106,6 +106,7 @@ endif
ifeq ($(BUILD_VARIANT),tc)
HAVE_ELF:=y
+ SHARED_LIBS:=y
endif
ifdef CONFIG_PACKAGE_devlink
@@ -127,7 +128,7 @@ TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libnl-tiny
MAKE_FLAGS += \
KERNEL_INCLUDE="$(LINUX_DIR)/user_headers/include" \
- SHARED_LIBS="" \
+ SHARED_LIBS=$(SHARED_LIBS) \
IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
HAVE_ELF=$(HAVE_ELF) \
HAVE_MNL=$(HAVE_MNL) \
@@ -161,6 +162,10 @@ define Package/tc/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_BIN) ./files/15-teql $(1)/etc/hotplug.d/iface/
+ifeq ($(SHARED_LIBS),y)
+ $(INSTALL_DIR) $(1)/usr/lib/tc
+ $(CP) $(PKG_BUILD_DIR)/tc/*.so $(1)/usr/lib/tc
+endif
endef
define Package/genl/install