aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iperf3/Makefile
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-08-01 14:04:55 -0600
committerJohn Crispin <john@phrozen.org>2017-08-23 20:35:16 +0200
commitfc48aebdc1d97c73ec8a8428d981bdaa850568d2 (patch)
treeaa6de47a250de7d10b6b2021009ebf933c7e593b /package/network/utils/iperf3/Makefile
parentd55fff4ae7c77cad820fe37cb3cad4ba6ced1eb8 (diff)
downloadupstream-fc48aebdc1d97c73ec8a8428d981bdaa850568d2.tar.gz
upstream-fc48aebdc1d97c73ec8a8428d981bdaa850568d2.tar.bz2
upstream-fc48aebdc1d97c73ec8a8428d981bdaa850568d2.zip
iperf3: add SSL variant for iperf_auth feature
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/network/utils/iperf3/Makefile')
-rw-r--r--package/network/utils/iperf3/Makefile36
1 files changed, 33 insertions, 3 deletions
diff --git a/package/network/utils/iperf3/Makefile b/package/network/utils/iperf3/Makefile
index 853636488c..1b94ce70fa 100644
--- a/package/network/utils/iperf3/Makefile
+++ b/package/network/utils/iperf3/Makefile
@@ -21,21 +21,39 @@ PKG_LICENSE:=BSD-3-Clause
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
include $(INCLUDE_DIR)/package.mk
DISABLE_NLS:=
-define Package/iperf3
+define Package/iperf3/default
SECTION:=net
CATEGORY:=Network
TITLE:=Internet Protocol bandwidth measuring tool
URL:=https://github.com/esnet/iperf
+endef
+
+define Package/iperf3
+$(call Package/iperf3/default)
+ VARIANT:=nossl
+endef
+
+define Package/iperf3-ssl
+$(call Package/iperf3/default)
+ TITLE+= with iperf_auth support
+ VARIANT:=ssl
DEPENDS:= +libopenssl
endef
TARGET_CFLAGS += -D_GNU_SOURCE
-CONFIGURE_ARGS += --disable-shared \
- --with-openssl="$(STAGING_DIR)/usr"
+CONFIGURE_ARGS += --disable-shared
+
+ifeq ($(BUILD_VARIANT),ssl)
+ CONFIGURE_ARGS += --with-openssl="$(STAGING_DIR)/usr"
+else
+ CONFIGURE_ARGS += --without-openssl
+endif
MAKE_FLAGS += noinst_PROGRAMS=
@@ -45,9 +63,21 @@ define Package/iperf3/description
characteristics.
endef
+# autoreconf fails if the README file isn't present
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ touch $(PKG_BUILD_DIR)/README
+endef
+
define Package/iperf3/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
endef
+define Package/iperf3-ssl/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/iperf3 $(1)/usr/bin/
+endef
+
$(eval $(call BuildPackage,iperf3))
+$(eval $(call BuildPackage,iperf3-ssl))