aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/ethtool
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-02-24 16:12:19 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-24 16:12:57 +0100
commit0f54d96d241dd3fb528ca14d9c0e6b799001feb6 (patch)
tree1659922c2cfc8fbb8f6ab5e66578eade67a01757 /package/network/utils/ethtool
parentf5984e0a0c8e2dae39fb381a6b7d209beba7fc3c (diff)
downloadupstream-0f54d96d241dd3fb528ca14d9c0e6b799001feb6.tar.gz
upstream-0f54d96d241dd3fb528ca14d9c0e6b799001feb6.tar.bz2
upstream-0f54d96d241dd3fb528ca14d9c0e6b799001feb6.zip
ethtool: import from packages, add myself as maintainer
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/utils/ethtool')
-rw-r--r--package/network/utils/ethtool/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/package/network/utils/ethtool/Makefile b/package/network/utils/ethtool/Makefile
new file mode 100644
index 0000000000..b36962601f
--- /dev/null
+++ b/package/network/utils/ethtool/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ethtool
+PKG_VERSION:=4.13
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@KERNEL/software/network/ethtool
+PKG_HASH:=b7c1a380007d30eaf261a63b3cfc000f9d93f9eb7626dcd48b5d2a733af99cba
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_CONFIG_DEPENDS:=ETHTOOL_PRETTY_DUMP
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ethtool
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Display or change ethernet card settings
+ URL:=http://www.kernel.org/pub/software/network/ethtool/
+endef
+
+define Package/ethtool/description
+ ethtool is a small utility for examining and tuning your ethernet-based
+ network interface
+endef
+
+define Package/ethtool/config
+ config ETHTOOL_PRETTY_DUMP
+ depends on PACKAGE_ethtool
+ bool "Enable pretty printing"
+endef
+
+ifeq ($(CONFIG_ETHTOOL_PRETTY_DUMP),y)
+CONFIGURE_ARGS += --enable-pretty-dump
+else
+CONFIGURE_ARGS += --disable-pretty-dump
+endif
+
+define Package/ethtool/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ethtool $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,ethtool))