aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/ebtables
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-05-15 14:00:37 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 07:52:44 +0100
commit2f2055de0edbb566322c7de8bd5e1523e2fecedc (patch)
treec6d7b665fd3f39e743cca6b431acff36bea17ebc /package/network/utils/ebtables
parent50789acf4e75606ffe16f1f6e7e3b7ee2e71185d (diff)
downloadupstream-2f2055de0edbb566322c7de8bd5e1523e2fecedc.tar.gz
upstream-2f2055de0edbb566322c7de8bd5e1523e2fecedc.tar.bz2
upstream-2f2055de0edbb566322c7de8bd5e1523e2fecedc.zip
ebtables: update to latest git 2018-05-15
66a9701 ebtables: Fix build errors and warnings 9fff3d5 include: Fix musl libc compatibility b1cdae8 extensions: Add string filter to ebtables Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> (backported from ac70ac3532fefa78c944d8a26c8df0ca5d88d04e) (rebased patches) Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/utils/ebtables')
-rw-r--r--package/network/utils/ebtables/Makefile6
-rw-r--r--package/network/utils/ebtables/patches/100-musl_fix.patch4
-rw-r--r--package/network/utils/ebtables/patches/200-fix-extension-init.patch11
3 files changed, 16 insertions, 5 deletions
diff --git a/package/network/utils/ebtables/Makefile b/package/network/utils/ebtables/Makefile
index baa8f2efed..5275c454f6 100644
--- a/package/network/utils/ebtables/Makefile
+++ b/package/network/utils/ebtables/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
-PKG_SOURCE_DATE:=2018-04-11
+PKG_SOURCE_DATE:=2018-05-15
PKG_RELEASE:=1
PKG_SOURCE_URL:=https://git.netfilter.org/ebtables
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=2e783b2277665c467138e7685309622456c41db4
-PKG_MIRROR_HASH:=601a41f579f76c8121bb6076ebcf5eb5efddf634ebb5949ec9e983a17e66e689
+PKG_SOURCE_VERSION:=66a97018a31eed416c6a25d051ea172e4d65be1b
+PKG_MIRROR_HASH:=3205285d4e92ab66d75681fd031b6bdc19954198b58dec1d8cbbf64312ebd445
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/ebtables/patches/100-musl_fix.patch b/package/network/utils/ebtables/patches/100-musl_fix.patch
index 3fe5845897..9528fe4b19 100644
--- a/package/network/utils/ebtables/patches/100-musl_fix.patch
+++ b/package/network/utils/ebtables/patches/100-musl_fix.patch
@@ -6,5 +6,5 @@
#define EBTABLES_U_H
+#define _NETINET_IF_ETHER_H
#include <netinet/in.h>
- #include <linux/netfilter_bridge/ebtables.h>
- #include <linux/netfilter/x_tables.h>
+ #include <netinet/ether.h>
+ #include <ebtables.h>
diff --git a/package/network/utils/ebtables/patches/200-fix-extension-init.patch b/package/network/utils/ebtables/patches/200-fix-extension-init.patch
index 52ab175ec2..4b202ac57e 100644
--- a/package/network/utils/ebtables/patches/200-fix-extension-init.patch
+++ b/package/network/utils/ebtables/patches/200-fix-extension-init.patch
@@ -247,3 +247,14 @@
{
ebt_register_table(&table);
}
+--- a/extensions/ebt_string.c
++++ b/extensions/ebt_string.c
+@@ -310,7 +310,7 @@ static struct ebt_u_match string_match =
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&string_match);
+ }