aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-05-27 15:13:48 -0700
committerJohn Crispin <john@phrozen.org>2018-05-30 06:38:19 +0200
commit7a20c7a05d52f9bb3c82742098457bfbed869a8a (patch)
tree20eaeb2330e71f613a9c79accdef18b9711cbb7a /package/network/utils/curl
parentf97946c49680a5fe713d0e2caaf072789f70e68d (diff)
downloadupstream-7a20c7a05d52f9bb3c82742098457bfbed869a8a.tar.gz
upstream-7a20c7a05d52f9bb3c82742098457bfbed869a8a.tar.bz2
upstream-7a20c7a05d52f9bb3c82742098457bfbed869a8a.zip
curl: Add ca-bundle dependency
While building, curl complains that the path specified is missing. Also, without ca-bundle, something like 'curl https://www.google.com' does not work due to a certificate verify error. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/network/utils/curl')
-rw-r--r--package/network/utils/curl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index ae8cc31edc..b4e3fd9d99 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.60.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -88,7 +88,7 @@ define Package/libcurl
CATEGORY:=Libraries
DEPENDS:= +LIBCURL_WOLFSSL:libwolfssl +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_MBEDTLS:libmbedtls
DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN2:libidn2
- DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2
+ DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2 +ca-bundle
TITLE:=A client-side URL transfer library
MENU:=1
endef