aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-12-03 16:07:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2016-12-03 16:38:44 +0100
commit4e07167eff3992150c6c2f414a0f3a88d5c42013 (patch)
tree32382fbcdb5427fd05ad2eff98500cd9a19a07f1 /package/network/utils/curl/patches
parent99ea26883bfc011a50902ec567fdb8d9f8b2f1ae (diff)
downloadupstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.tar.gz
upstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.tar.bz2
upstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.zip
curl: update to version 7.51.0
This fixes the following security problems: CVE-2016-8615: cookie injection for other servers CVE-2016-8616: case insensitive password comparison CVE-2016-8617: OOB write via unchecked multiplication CVE-2016-8618: double-free in curl_maprintf CVE-2016-8619: double-free in krb5 code CVE-2016-8620: glob parser write/read out of bounds CVE-2016-8621: curl_getdate read out of bounds CVE-2016-8622: URL unescape heap overflow via integer truncation CVE-2016-8623: Use-after-free via shared cookies CVE-2016-8624: invalid URL parsing with '#' CVE-2016-8625: IDNA 2003 makes curl use wrong host Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/utils/curl/patches')
-rw-r--r--package/network/utils/curl/patches/200-no_docs_tests.patch4
-rw-r--r--package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/package/network/utils/curl/patches/200-no_docs_tests.patch b/package/network/utils/curl/patches/200-no_docs_tests.patch
index 6f86d4c6cb..139c05e64b 100644
--- a/package/network/utils/curl/patches/200-no_docs_tests.patch
+++ b/package/network/utils/curl/patches/200-no_docs_tests.patch
@@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -150,7 +150,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -153,7 +153,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include
@@ -11,7 +11,7 @@
pkgconfig_DATA = libcurl.pc
--- a/Makefile.in
+++ b/Makefile.in
-@@ -611,7 +611,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -613,7 +613,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include
diff --git a/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch b/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
index 464f2fcfed..a26caa8571 100644
--- a/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
+++ b/package/network/utils/curl/patches/310-polarssl-disable-runtime-version-check.patch
@@ -1,6 +1,6 @@
--- a/lib/vtls/polarssl.c
+++ b/lib/vtls/polarssl.c
-@@ -665,7 +665,7 @@ void Curl_polarssl_session_free(void *pt
+@@ -646,7 +646,7 @@ void Curl_polarssl_session_free(void *pt
size_t Curl_polarssl_version(char *buffer, size_t size)
{
@@ -11,7 +11,7 @@
version>>24, (version>>16)&0xff, (version>>8)&0xff);
--- a/lib/vtls/mbedtls.c
+++ b/lib/vtls/mbedtls.c
-@@ -713,7 +713,7 @@ void Curl_mbedtls_session_free(void *ptr
+@@ -712,7 +712,7 @@ void Curl_mbedtls_session_free(void *ptr
size_t Curl_mbedtls_version(char *buffer, size_t size)
{