aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-12-03 16:07:47 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2016-12-03 16:38:44 +0100
commit4e07167eff3992150c6c2f414a0f3a88d5c42013 (patch)
tree32382fbcdb5427fd05ad2eff98500cd9a19a07f1 /package/network/utils/curl/Makefile
parent99ea26883bfc011a50902ec567fdb8d9f8b2f1ae (diff)
downloadupstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.tar.gz
upstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.tar.bz2
upstream-4e07167eff3992150c6c2f414a0f3a88d5c42013.zip
curl: update to version 7.51.0
This fixes the following security problems: CVE-2016-8615: cookie injection for other servers CVE-2016-8616: case insensitive password comparison CVE-2016-8617: OOB write via unchecked multiplication CVE-2016-8618: double-free in curl_maprintf CVE-2016-8619: double-free in krb5 code CVE-2016-8620: glob parser write/read out of bounds CVE-2016-8621: curl_getdate read out of bounds CVE-2016-8622: URL unescape heap overflow via integer truncation CVE-2016-8623: Use-after-free via shared cookies CVE-2016-8624: invalid URL parsing with '#' CVE-2016-8625: IDNA 2003 makes curl use wrong host Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/utils/curl/Makefile')
-rw-r--r--package/network/utils/curl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index b9b3e72377..d1e8097602 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
-PKG_VERSION:=7.50.3
+PKG_VERSION:=7.51.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
ftp://ftp.planetmirror.com/pub/curl/ \
http://www.mirrormonster.com/curl/download/ \
http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=7b7347d976661d02c84a1f4d6daf40dee377efdc45b9e2c77dedb8acf140d8ec
+PKG_MD5SUM:=7f8240048907e5030f67be0a6129bc4b333783b9cca1391026d700835a788dde
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING