aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-08 08:01:20 +0000
committerJohn Crispin <john@openwrt.org>2014-10-08 08:01:20 +0000
commit90120bb7712361d67edb84faee78f2b191e1158b (patch)
tree09269a89a6d98cd7f0c5589f07ff37556b896e1c /package/network/utils/comgt/Makefile
parent1df98fcd5adbf50c9fb0d2718879616d0e3c67b8 (diff)
downloadupstream-90120bb7712361d67edb84faee78f2b191e1158b.tar.gz
upstream-90120bb7712361d67edb84faee78f2b191e1158b.tar.bz2
upstream-90120bb7712361d67edb84faee78f2b191e1158b.zip
wwan: add a generic 3g/4g proto
this proto handler will detect which of 3g, qmi, mbim, ncm or directip you need for a stick and setup uci automagically Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 42837
Diffstat (limited to 'package/network/utils/comgt/Makefile')
-rw-r--r--package/network/utils/comgt/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 21dda8bd56..11a1a49139 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -73,6 +73,9 @@ define Package/comgt/install
$(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+ $(INSTALL_BIN) ./files/directip.sh $(1)/lib/netifd/proto/directip.sh
+ $(INSTALL_DIR) $(1)/lib/network/wwan/
+ $(INSTALL_DATA) ./files/data/* $(1)/lib/network/wwan/
endef
define Package/comgt-directip/install