aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-10 08:56:33 +0000
committerJohn Crispin <john@openwrt.org>2014-10-10 08:56:33 +0000
commit51a5ff094703c4db984284913d605e83e819d99c (patch)
tree7e5206fa9f0cb29d8c80b2190e8be7d682afdfff /package/network/utils/comgt/Makefile
parentd83efbadee946ced7f1bad1ea4d7fd8b9d372d10 (diff)
downloadupstream-51a5ff094703c4db984284913d605e83e819d99c.tar.gz
upstream-51a5ff094703c4db984284913d605e83e819d99c.tar.bz2
upstream-51a5ff094703c4db984284913d605e83e819d99c.zip
comgt: add ncm proto support
This will not work for all board/dongle combinations until we hit 3.17. Signed-off-by: Matti Laakso <malaakso@elisanet.fi> SVN-Revision: 42866
Diffstat (limited to 'package/network/utils/comgt/Makefile')
-rw-r--r--package/network/utils/comgt/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 11a1a49139..5fccd947e6 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -40,6 +40,12 @@ $(call Package/comgt/Default)
DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-sierrawireless +kmod-usb-net +kmod-usb-net-sierrawireless
endef
+define Package/comgt-ncm
+$(call Package/comgt/Default)
+ TITLE+=NCM 3G/4G Support
+ DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-option +kmod-usb-net +kmod-usb-net-cdc-ncm +kmod-usb-net-huawei-cdc-ncm
+endef
+
define Package/comgt/description
comgt is a scripting language interpreter useful for establishing
communications on serial lines and through PCMCIA modems as well as GPRS
@@ -86,5 +92,14 @@ define Package/comgt-directip/install
$(INSTALL_BIN) ./files/directip.sh $(1)/lib/netifd/proto/directip.sh
endef
+define Package/comgt-ncm/install
+ $(INSTALL_DIR) $(1)/etc/gcom
+ $(INSTALL_DATA) ./files/ncm.json $(1)/etc/gcom/ncm.json
+ $(INSTALL_DATA) ./files/runcommand.gcom $(1)/etc/gcom/runcommand.gcom
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/ncm.sh $(1)/lib/netifd/proto/ncm.sh
+endef
+
$(eval $(call BuildPackage,comgt))
$(eval $(call BuildPackage,comgt-directip))
+$(eval $(call BuildPackage,comgt-ncm))