aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-28 19:19:33 +0000
committerJohn Crispin <john@openwrt.org>2015-01-28 19:19:33 +0000
commit623716dd4318cd05022d5d1bb0875906ddfc12c2 (patch)
tree23a4656d291af5d8234b6263c97dedecb73d1a24 /package/network/utils/comgt/Makefile
parente25e6df2cf38de386cc5d06ec9b1e33ab3bce638 (diff)
downloadupstream-623716dd4318cd05022d5d1bb0875906ddfc12c2.tar.gz
upstream-623716dd4318cd05022d5d1bb0875906ddfc12c2.tar.bz2
upstream-623716dd4318cd05022d5d1bb0875906ddfc12c2.zip
comgt-ncm: Fix NCM protocol
This patch fixes the NCM protocol by adding the missing ifname to the netifd script and changing one unintended "send" statement to "print" in runcommand.gcom. It also cleans up logging and makes the manufacturer names case-insensitive. Furthermore, comgt-ncm should not depend on the USB-serial-related kernel modules, as the cdc-wdm control device works without them. There is also no need to depend on kmod-huawei-cdc-ncm, since other manufacturers (like Sony-Ericsson and Samsung) which use other kernel modules should also be supported. I'd appreciate if someone with Samsung or Sony-Ericsson modems could test this, I was only able to test it with Huawei E3276, E3372 and E353. Signed-off-by: Matti Laakso <malaakso@elisanet.fi> SVN-Revision: 44182
Diffstat (limited to 'package/network/utils/comgt/Makefile')
-rw-r--r--package/network/utils/comgt/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 9ab2f14e8c..500365aaab 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -44,7 +44,7 @@ endef
define Package/comgt-ncm
$(call Package/comgt/Default)
TITLE+=NCM 3G/4G Support
- DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-option +kmod-usb-net +kmod-usb-net-cdc-ncm +kmod-usb-net-huawei-cdc-ncm
+ DEPENDS:=+comgt
endef
define Package/comgt/description