aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-11-14 21:18:13 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2021-11-14 21:26:41 +0200
commit53247d3cb43e1ecc5feef1753ca541e3c8f76110 (patch)
tree542d47d644f210145239b1e9b84c7c3ee5082a0f /package/network/services
parentd44ab665a6b848422657ce19e3d6c6e76fed0dc2 (diff)
downloadupstream-53247d3cb43e1ecc5feef1753ca541e3c8f76110.tar.gz
upstream-53247d3cb43e1ecc5feef1753ca541e3c8f76110.tar.bz2
upstream-53247d3cb43e1ecc5feef1753ca541e3c8f76110.zip
lldpd: add reload trigger
This is needed to reload the service when calling reload_config, if the UCI config has changed. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/lldpd/Makefile2
-rw-r--r--package/network/services/lldpd/files/lldpd.init4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index fcfbc18286..8eb7e35716 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lldpd
PKG_VERSION:=1.0.13
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
diff --git a/package/network/services/lldpd/files/lldpd.init b/package/network/services/lldpd/files/lldpd.init
index 74fece7227..5b39144921 100644
--- a/package/network/services/lldpd/files/lldpd.init
+++ b/package/network/services/lldpd/files/lldpd.init
@@ -56,6 +56,10 @@ write_lldpd_conf()
[ -e $LLDPD_CONFS_DIR ] || ln -s /etc/lldpd.d $LLDPD_CONFS_DIR
}
+service_triggers() {
+ procd_add_reload_trigger "lldpd"
+}
+
start_service() {
local enable_cdp