aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-16 12:25:06 +0000
commit7105a54bcb1ec09bd71ed530ef16ac39a08c06c3 (patch)
treed2268e094f43ad915138f40df3e8501203f45bd1 /package/network/services
parent36da43e2deb597cecf6ed8ef8f2fb042cde7c83e (diff)
downloadupstream-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.tar.gz
upstream-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.tar.bz2
upstream-7105a54bcb1ec09bd71ed530ef16ac39a08c06c3.zip
packages: some (e)glibc fixes after r44701
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44842 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/igmpproxy/Makefile2
-rw-r--r--package/network/services/lldpd/Makefile2
-rw-r--r--package/network/services/samba36/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d1bbab86e7..eeba02802a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -89,7 +89,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
-ifdef CONFIG_USE_EGLIBC
+ifdef CONFIG_USE_GLIBC
TARGET_LDFLAGS += -lrt
TARGET_LDFLAGS_C += -lrt
endif
diff --git a/package/network/services/igmpproxy/Makefile b/package/network/services/igmpproxy/Makefile
index 33ed014040..03ad25819b 100644
--- a/package/network/services/igmpproxy/Makefile
+++ b/package/network/services/igmpproxy/Makefile
@@ -25,7 +25,7 @@ define Package/igmpproxy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Routing and Redirection
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
TITLE:=Multicast Routing Daemon
URL:=http://sourceforge.net/projects/igmpproxy
endef
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 6f97f45e65..f038a340ac 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -31,7 +31,7 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+ DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
USERID:=lldp=121:lldp=129
MENU:=1
endef
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index d4c96d3854..70dfb2b16f 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -35,7 +35,7 @@ define Package/samba36-server
CATEGORY:=Network
TITLE:=Samba 3.6 SMB/CIFS server
URL:=http://www.samba.org/
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
endef
define Package/samba36-client