aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-30 19:26:55 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2020-01-05 19:36:45 +0100
commit121ad10601a072959c02e6f4c139169333fc2200 (patch)
treecc88fcae638f800e03490e2e2eef3027252417c2 /package/network/services
parent43eb93441fa33822cb1871a758cad892baeb8cce (diff)
downloadupstream-121ad10601a072959c02e6f4c139169333fc2200.tar.gz
upstream-121ad10601a072959c02e6f4c139169333fc2200.tar.bz2
upstream-121ad10601a072959c02e6f4c139169333fc2200.zip
lldpd: Fix compilation without fortify-headers
Upstream backport. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/lldpd/Makefile2
-rw-r--r--package/network/services/lldpd/patches/001-disable_libcap.patch6
-rw-r--r--package/network/services/lldpd/patches/010-limits.patch19
3 files changed, 23 insertions, 4 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 5b36155b71..eb1fe6539d 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lldpd
PKG_VERSION:=1.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
diff --git a/package/network/services/lldpd/patches/001-disable_libcap.patch b/package/network/services/lldpd/patches/001-disable_libcap.patch
index 850d493c6f..9b03d84381 100644
--- a/package/network/services/lldpd/patches/001-disable_libcap.patch
+++ b/package/network/services/lldpd/patches/001-disable_libcap.patch
@@ -1,6 +1,6 @@
---- a/configure.ac 2019-04-30 17:04:53.542449926 +0300
-+++ b/configure.ac 2019-04-30 17:06:26.974453867 +0300
-@@ -244,7 +244,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -244,7 +244,13 @@ PKG_CHECK_MODULES([check], [check >= 0.9
# Third-party libraries
lldp_CHECK_LIBEVENT
diff --git a/package/network/services/lldpd/patches/010-limits.patch b/package/network/services/lldpd/patches/010-limits.patch
new file mode 100644
index 0000000000..1672145384
--- /dev/null
+++ b/package/network/services/lldpd/patches/010-limits.patch
@@ -0,0 +1,19 @@
+From b2eebb31fc21b5ce12ef8944b50088119f1b9427 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Mon, 25 Mar 2019 18:43:03 +0100
+Subject: [PATCH] priv: include limits.h for PATH_MAX
+
+---
+ src/daemon/priv.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/daemon/priv.c
++++ b/src/daemon/priv.c
+@@ -27,6 +27,7 @@
+ #include <unistd.h>
+ #include <signal.h>
+ #include <errno.h>
++#include <limits.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>