aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-25 12:46:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-25 12:46:35 +0000
commit8e18457f04d52eff970bebc743907b75d8baeffc (patch)
tree502c54dc28e6ce95cf8055fd58856ead09909889 /package/network/services
parent0347465420399eb8bf72c454ebc1d58d9bda2858 (diff)
downloadupstream-8e18457f04d52eff970bebc743907b75d8baeffc.tar.gz
upstream-8e18457f04d52eff970bebc743907b75d8baeffc.tar.bz2
upstream-8e18457f04d52eff970bebc743907b75d8baeffc.zip
BB: uhttpd: do not configure TLS parameters if libustream-ssl is not present
A quite frequent problem after sysupgrading from an older, SSL enabled build is that ustream-ssl is not installed so uhttpd fails to come up again due to https listening directives in the preserved configuration. Skip key/cert and ssl listen options when libustream-ssl.so is not present. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42284 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42286 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index ba2ca55b04..a93b40a085 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2013 Jo-Philipp Wich <jow@openwrt.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <jow@openwrt.org>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2014-06-11
+PKG_VERSION:=2014-08-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index 608aa9d36b..2e94609606 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -109,7 +109,7 @@ start_instance()
config_get UHTTPD_KEY "$cfg" key /etc/uhttpd.key
config_get UHTTPD_CERT "$cfg" cert /etc/uhttpd.crt
- [ -n "$https" ] && {
+ [ -f /lib/libustream-ssl.so ] && [ -n "$https" ] && {
[ -f "$UHTTPD_CERT" -a -f "$UHTTPD_KEY" ] || {
config_foreach generate_keys cert
}