aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-18 10:04:02 +0000
committerSteven Barth <steven@midlink.org>2014-06-18 10:04:02 +0000
commit06e56f40f6e0f838890aa6176f7487d7f643f68c (patch)
treed605b57e279623a484e5a709997596b46b26305f /package/network/services
parentbb3c6eaa04947e9322c1cd348e684fbdc60f8b6c (diff)
downloadupstream-06e56f40f6e0f838890aa6176f7487d7f643f68c.tar.gz
upstream-06e56f40f6e0f838890aa6176f7487d7f643f68c.tar.bz2
upstream-06e56f40f6e0f838890aa6176f7487d7f643f68c.zip
dnsmasq: use COPTS for compile time options
As documented in config.h. Doing otherwise will break dnsmasq's pkg-wrapper script to find its libs to link to. Signed-off-by: Andre Heider <a.heider@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41241 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/dnsmasq/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 8e2d41c243..c0d3dc4f48 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -61,18 +61,19 @@ endef
Package/dnsmasq-dhcpv6/conffiles = $(Package/dnsmasq/conffiles)
-TARGET_CFLAGS += \
- -ffunction-sections -fdata-sections \
- $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
+COPTS = $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
ifeq ($(BUILD_VARIANT),nodhcpv6)
- TARGET_CFLAGS += -DNO_DHCP6
+ COPTS += -DNO_DHCP6
endif
MAKE_FLAGS := \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="-Wl,--gc-sections" \
+ COPTS="$(COPTS)" \
PREFIX="/usr"
define Package/dnsmasq/install