aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/wireguard/Makefile
diff options
context:
space:
mode:
authorAleksandr V. Piskunov <aleksandr.v.piskunov@gmail.com>2018-07-01 15:40:31 +0300
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-07-25 11:23:35 +0100
commitf91a0f3b1aba95bcf3b248e02a89709ce0274fa7 (patch)
tree88791075a47a725ef05066ea705f148848250386 /package/network/services/wireguard/Makefile
parentf1dbfa193768993e0c00faf9ca62e33c23f32938 (diff)
downloadupstream-f91a0f3b1aba95bcf3b248e02a89709ce0274fa7.tar.gz
upstream-f91a0f3b1aba95bcf3b248e02a89709ce0274fa7.tar.bz2
upstream-f91a0f3b1aba95bcf3b248e02a89709ce0274fa7.zip
wireguard-tools: add wireguard_watchdog script
This watchdog script tries to re-resolve hostnames for inactive WireGuard peers. Use it for peers with a frequently changing dynamic IP. persistent_keepalive must be set, recommended value is 25 seconds. Run this script from cron every minute: echo '* * * * * /usr/bin/wireguard_watchdog' >> /etc/crontabs/root Signed-off-by: Aleksandr V. Piskunov <aleksandr.v.piskunov@gmail.com> [bump the package release] Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> (cherry picked from commit 20c4819c7baf6f9b91420849caf30e5137bd75d6)
Diffstat (limited to 'package/network/services/wireguard/Makefile')
-rw-r--r--package/network/services/wireguard/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/network/services/wireguard/Makefile b/package/network/services/wireguard/Makefile
index 9965002712..a88dca1e7f 100644
--- a/package/network/services/wireguard/Makefile
+++ b/package/network/services/wireguard/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=wireguard
PKG_VERSION:=0.0.20180718
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
@@ -84,12 +84,13 @@ define Package/wireguard-tools/description
$(call Package/wireguard/Default/description)
This package provides the userspace control program for WireGuard,
- `wg(8)`, and a netifd protocol helper.
+ `wg(8)`, a netifd protocol helper, and a re-resolve watchdog script.
endef
define Package/wireguard-tools/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tools/wg $(1)/usr/bin/
+ $(INSTALL_BIN) ./files/wireguard_watchdog $(1)/usr/bin/
$(INSTALL_DIR) $(1)/lib/netifd/proto/
$(INSTALL_BIN) ./files/wireguard.sh $(1)/lib/netifd/proto/
endef