aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/unetd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-08-23 23:29:52 +0200
committerFelix Fietkau <nbd@nbd.name>2022-08-27 15:24:58 +0200
commit104de8abe455405d43133edc551d50645934d5be (patch)
tree0e27f42b200d35810960ece42d1e88a7ea74ac69 /package/network/services/unetd/Makefile
parent09b086eecaa545cf7f30bc7e394a32751e25db65 (diff)
downloadupstream-104de8abe455405d43133edc551d50645934d5be.tar.gz
upstream-104de8abe455405d43133edc551d50645934d5be.tar.bz2
upstream-104de8abe455405d43133edc551d50645934d5be.zip
unetd: add WireGuard based VPN connection manager for OpenWrt
This package simplifies setting up wireguard networks on OpenWrt by a wireguard network as a JSON file, which can be shared across all participating nodes. It can be signed with an authentication key and automatically kept in sync. unetd also supports deterministically generating ipv6 addresses for each host based on the public key and storing those in a hosts file that can be used with dnsmasq. It also supports automatically creating VXLAN tunnels between multiple endpoints. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/unetd/Makefile')
-rw-r--r--package/network/services/unetd/Makefile83
1 files changed, 83 insertions, 0 deletions
diff --git a/package/network/services/unetd/Makefile b/package/network/services/unetd/Makefile
new file mode 100644
index 0000000000..3a61ed43bb
--- /dev/null
+++ b/package/network/services/unetd/Makefile
@@ -0,0 +1,83 @@
+#
+# Copyright (C) 2022 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=unetd
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/unetd.git
+PKG_SOURCE_DATE:=2022-08-25
+PKG_SOURCE_VERSION:=d8220b098010041232374761fee258a8deff0865
+PKG_MIRROR_HASH:=6efced0eb451f6ac5d7facec3f45ce7f6928fae4481650ffcebf3b6434478550
+
+PKG_LICENSE:=GPL-2.0
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+
+PKG_BUILD_DEPENDS:=bpf-headers
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+include $(INCLUDE_DIR)/bpf.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/unetd
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=WireGuard based VPN connection manager for OpenWrt
+ DEPENDS:=+libubox +libubus +libblobmsg-json +libnl-tiny +kmod-wireguard +libbpf $(BPF_DEPENDS)
+endef
+
+define Package/unet-cli
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=unetd +ucode +ucode-mod-fs
+ TITLE:=unetd administration command line utility
+endef
+
+TARGET_CFLAGS += \
+ -I$(STAGING_DIR)/usr/include/libnl-tiny \
+ -I$(STAGING_DIR)/usr/include
+
+CMAKE_OPTIONS += \
+ -DLIBNL_LIBS=-lnl-tiny
+
+define Build/Compile
+ $(call CompileBPF,$(PKG_BUILD_DIR)/mss-bpf.c)
+ $(call Build/Compile/Default,)
+endef
+
+define Package/unetd/conffiles
+/etc/unetd
+endef
+
+define Package/unetd/install
+ $(INSTALL_DIR) \
+ $(1)/etc/unetd \
+ $(1)/lib/bpf \
+ $(1)/etc/init.d \
+ $(1)/lib/netifd/proto \
+ $(1)/usr/sbin \
+ $(1)/usr/lib
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libunet.so* $(1)/usr/lib/
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/sbin/unetd \
+ $(PKG_INSTALL_DIR)/usr/sbin/unet-tool \
+ $(1)/usr/sbin/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/mss-bpf.o $(1)/lib/bpf/mss.o
+ $(INSTALL_BIN) ./files/unetd.init $(1)/etc/init.d/unetd
+ $(INSTALL_BIN) ./files/unetd.sh $(1)/lib/netifd/proto
+endef
+
+define Package/unet-cli/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/scripts/unet-cli $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,unetd))
+$(eval $(call BuildPackage,unet-cli))