aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-23 09:07:23 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-23 09:18:04 +0200
commit214146c6f298e593695c29b8c04a418dac914040 (patch)
tree6e87d7ee4acccecf7e668ae70c61bd666c1a8695 /package/network/services/uhttpd/Makefile
parent7e73e9128f6a63b9198c88eea97c267810447be4 (diff)
downloadupstream-214146c6f298e593695c29b8c04a418dac914040.tar.gz
upstream-214146c6f298e593695c29b8c04a418dac914040.tar.bz2
upstream-214146c6f298e593695c29b8c04a418dac914040.zip
uhttpd: support multiple Lua prefixes
Update to latest git HEAD in order to support configuring multiple concurrent Lua prefixes in a single uhttpd instance: b741dec lua: support multiple Lua prefixes Additionally rework the init script and update the default configuration example to treat the lua_prefix option as key=value uci list, similar to the interpreter extension mapping. Support for the old "option lua_prefix" plus "option lua_handler" notation is still present. Finally drop the sed postinstall hack in uhttpd-mod-lua to avoid mangling files belonging to other packages. Since Lua prefixes have precedence over CGI prefixes, simply register `/cgi-bin/luci` as Lua handler which will only become active if both luci-base and uhttpd-mod-lua is installed. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/services/uhttpd/Makefile')
-rw-r--r--package/network/services/uhttpd/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 9df6050480..af322b53b6 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/uhttpd.git
-PKG_SOURCE_DATE:=2018-08-21
-PKG_SOURCE_VERSION:=952bf9d754d021ee9c08f9add5c9af53aaaf39ae
-PKG_MIRROR_HASH:=34cd66b4c8b4a384e31f3821a4536854491ed2cd62f49c7ae0b0cd4381f061dd
+PKG_SOURCE_DATE:=2018-08-23
+PKG_SOURCE_VERSION:=b741dec35698a80266fb8206970638e666774a33
+PKG_MIRROR_HASH:=2f7c88ba1b36dd6776a7d954b4c5e96aff288992acf19152a38641c665e261e4
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=ISC
@@ -107,16 +107,6 @@ define Package/uhttpd-mod-ubus/install
$(INSTALL_DATA) ./files/ubus.default $(1)/etc/uci-defaults/00_uhttpd_ubus
endef
-define Package/uhttpd-mod-lua/postinst
- $(if $(CONFIG_uhttpd_lua),
- #!/bin/sh
- if [ -f $${IPKG_INSTROOT}/www/index.html ]
- then
- sed -e 's:/cgi-bin::g' -i $${IPKG_INSTROOT}/www/index.html
- fi
- ,)
-endef
-
$(eval $(call BuildPackage,uhttpd))
$(eval $(call BuildPackage,uhttpd-mod-lua))