aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/ppp
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-06-10 10:42:34 +0000
committerSteven Barth <steven@midlink.org>2013-06-10 10:42:34 +0000
commit5882e71509c23e5d14d47f72c00e630537034487 (patch)
tree15af6b14103498cf6290e274d5d009940ef04bba /package/network/services/ppp
parent5bab66f331f7b75f1eee267abd0edbca2e4397ce (diff)
downloadupstream-5882e71509c23e5d14d47f72c00e630537034487.tar.gz
upstream-5882e71509c23e5d14d47f72c00e630537034487.tar.bz2
upstream-5882e71509c23e5d14d47f72c00e630537034487.zip
ppp: correctly handle address when reloading
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36904 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/ppp')
-rw-r--r--package/network/services/ppp/Makefile2
-rwxr-xr-xpackage/network/services/ppp/files/lib/netifd/ppp-up2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 9a4640bf1c..d4aab3831f 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.5
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/network/services/ppp/files/lib/netifd/ppp-up b/package/network/services/ppp/files/lib/netifd/ppp-up
index d488b8d5f8..fa14550ec4 100755
--- a/package/network/services/ppp/files/lib/netifd/ppp-up
+++ b/package/network/services/ppp/files/lib/netifd/ppp-up
@@ -5,7 +5,7 @@ PPP_IPPARAM="$6"
proto_init_update "$IFNAME" 1 1
proto_set_keep 1
[ -n "$PPP_IPPARAM" ] && {
- [ -n "$IPLOCAL" ] && proto_add_ipv4_address "$IPLOCAL" 32
+ [ -n "$IPLOCAL" ] && proto_add_ipv4_address "$IPLOCAL" 32 "" "${IPREMOTE:-2.2.2.2}"
[ -n "$IPREMOTE" ] && proto_add_ipv4_route 0.0.0.0 0 "$IPREMOTE"
[ -n "$LLLOCAL" ] && proto_add_ipv6_address "$LLLOCAL" 128
[ -n "$DNS1" ] && proto_add_dns_server "$DNS1"