aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/ppp/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-02 21:33:38 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-03-21 18:28:22 +0100
commit07730ff3465d3cede3026cdd1c17453930f055ce (patch)
tree71c8f06b42de3b1ff0d1c02c0068d718c3a08a62 /package/network/services/ppp/Makefile
parentda3700988d9e34e380bae21ee23d5458a7e972b4 (diff)
downloadupstream-07730ff3465d3cede3026cdd1c17453930f055ce.tar.gz
upstream-07730ff3465d3cede3026cdd1c17453930f055ce.tar.bz2
upstream-07730ff3465d3cede3026cdd1c17453930f055ce.zip
treewide: add support for "lto" in PKG_BUILD_FLAGS
This reduces open coding and allows to easily add a knob to enable it treewide, where chosen packages can still opt-out via "no-lto". Some packages used LTO, but not the linker plugin. This unifies 'em all to attempt to produce better code. Quoting man gcc(1): "This improves the quality of optimization by exposing more code to the link-time optimizer." Also use -flto=auto instead of -flto=jobserver, as it's not guaranteed that every buildsystem uses +$(MAKE) correctly. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/network/services/ppp/Makefile')
-rw-r--r--package/network/services/ppp/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 48f2091a1f..80d5e46c34 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -26,7 +26,7 @@ PKG_VERSION:=$(PKG_RELEASE_VERSION).git-$(PKG_SOURCE_DATE)
PKG_BUILD_DEPENDS:=libpcap
PKG_ASLR_PIE_REGULAR:=1
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -193,9 +193,6 @@ $(call Build/Configure/Default,, \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto -fuse-linker-plugin
-
MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
PRECOMPILED_FILTER=1 \
STAGING_DIR="$(STAGING_DIR)"