aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/ppp/Makefile
diff options
context:
space:
mode:
authorFlorian Eckert <Eckert.Florian@googlemail.com>2017-02-07 15:32:08 +0100
committerHans Dedecker <hans.dedecker@technicolor.com>2017-02-13 18:45:34 +0100
commitbb9d2aa8681a9ea975ff86ec03d73ffc16e6534d (patch)
tree7ed0bd0eba4bbc610c3bda70365f4b87cffd3cff /package/network/services/ppp/Makefile
parentc0841b3c4e0cc184cf2079c69fe84d11c483afcc (diff)
downloadupstream-bb9d2aa8681a9ea975ff86ec03d73ffc16e6534d.tar.gz
upstream-bb9d2aa8681a9ea975ff86ec03d73ffc16e6534d.tar.bz2
upstream-bb9d2aa8681a9ea975ff86ec03d73ffc16e6534d.zip
ppp: add pppoe-discovery to an independent package
pppoe-discovery performs the same discovery process as pppoe, but does not initiate a session Signed-off-by: Florian Eckert <Eckert.Florian@googlemail.com> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/services/ppp/Makefile')
-rw-r--r--package/network/services/ppp/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 669e6534fe..2b04afddc4 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -158,6 +158,17 @@ define Package/pppstats/description
This package contains an utility to report PPP statistics.
endef
+define Package/pppoe-discovery
+$(call Package/ppp/Default)
+ DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +ppp-mod-pppoe
+ TITLE:=Perform a PPPoE-discovery process
+endef
+
+define Package/pppoe-discovery/description
+This tool performs the same discovery process as pppoe, but does
+not initiate a session. Can be useful to debug pppoe.
+endef
+
define Build/Configure
$(call Build/Configure/Default,, \
@@ -274,6 +285,11 @@ define Package/pppstats/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppstats $(1)/usr/sbin/
endef
+define Package/pppoe-discovery/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/pppoe-discovery $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,ppp))
$(eval $(call BuildPackage,ppp-multilink))
$(eval $(call BuildPackage,ppp-mod-pppoa))
@@ -285,3 +301,4 @@ $(eval $(call BuildPackage,ppp-mod-passwordfd))
$(eval $(call BuildPackage,chat))
$(eval $(call BuildPackage,pppdump))
$(eval $(call BuildPackage,pppstats))
+$(eval $(call BuildPackage,pppoe-discovery))