aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/lldpd
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-13 08:38:25 +0000
committerJohn Crispin <john@openwrt.org>2015-03-13 08:38:25 +0000
commit31b8de458787a3e935f4181363092543be6b99f6 (patch)
treebe3af3edef0ffeae737338b8e1dd13484c53a48a /package/network/services/lldpd
parentd8e61b088f5cdfafdd2301b04bc3c4e4b3ebc9e4 (diff)
downloadupstream-31b8de458787a3e935f4181363092543be6b99f6.tar.gz
upstream-31b8de458787a3e935f4181363092543be6b99f6.tar.bz2
upstream-31b8de458787a3e935f4181363092543be6b99f6.zip
lldpd: make LLDP-MED, DOT1 and DOT3 extensions disable-able
The names for the config options were taken from lldpd's configure.ac file. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> SVN-Revision: 44743
Diffstat (limited to 'package/network/services/lldpd')
-rw-r--r--package/network/services/lldpd/Config.in16
-rw-r--r--package/network/services/lldpd/Makefile3
2 files changed, 19 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
index c7d47953af..a416490425 100644
--- a/package/network/services/lldpd/Config.in
+++ b/package/network/services/lldpd/Config.in
@@ -21,8 +21,24 @@ config LLDPD_WITH_SONMP
default y
prompt "Enable support for the SynOptics Network Management Protocol"
+config LLDPD_WITH_LLDPMED
+ bool
+ prompt "Enable LLDP-MED extension"
+ default y
+
+config LLDPD_WITH_DOT1
+ bool
+ prompt "Enable Dot1 extension (VLAN stuff)"
+ default y
+
+config LLDPD_WITH_DOT3
+ bool
+ prompt "Enable Dot3 extension (PHY stuff)"
+ default y
+
config LLDPD_WITH_JSON
bool
prompt "Enable JSON output for the LLDP Command-Line Interface"
default n
+
endmenu
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 5a1921e9d0..6f97f45e65 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -85,6 +85,9 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
$(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
$(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+ $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
+ $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
+ $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
$(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)