aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/lldpd/Makefile
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2015-10-21 16:11:09 +0300
committerJo-Philipp Wich <jo@mein.io>2016-10-31 12:51:15 +0100
commit909f0630663d7ae1471c76154516e3299992a150 (patch)
treea0c984dd7e376a8f92aac0f08169b8865766f353 /package/network/services/lldpd/Makefile
parentccf0648e725b8edcb61ddd1dd7b4d51526f31c68 (diff)
downloadupstream-909f0630663d7ae1471c76154516e3299992a150.tar.gz
upstream-909f0630663d7ae1471c76154516e3299992a150.tar.bz2
upstream-909f0630663d7ae1471c76154516e3299992a150.zip
lldpd: fix reload function for when interfaces change
The problem is that interfaces are specified at start as command line arguments, making them unchange-able via reload. That means, we have to move (since lldpd allows this) the interfaces-match-pattern option to be in a config file and reload the configuration. It's either that, or do a 'restart'. Since we're generating the lldpd.conf file, we'll have to move the 'sysconfdir' of lldpd to /tmp, where the files will get written ; this will prevent any unncessary flash writes. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package/network/services/lldpd/Makefile')
-rw-r--r--package/network/services/lldpd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index b2b1f3815d..ff15057aa5 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -94,6 +94,7 @@ CONFIGURE_ARGS += \
--with-embedded-libevent=no \
--disable-hardening \
--without-xml \
+ --sysconfdir=/tmp \
$(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
$(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
$(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \