aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/lldpd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 16:19:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 16:19:38 +0000
commit8df45565e92a1712f5e25d101104319a4c5dcf7f (patch)
treefba4e19a5c05a909b4fb825c13ef543adc91f011 /package/network/services/lldpd/Makefile
parent7d44f7630f172047c6e936bc3caef61005abc779 (diff)
downloadupstream-8df45565e92a1712f5e25d101104319a4c5dcf7f.tar.gz
upstream-8df45565e92a1712f5e25d101104319a4c5dcf7f.tar.bz2
upstream-8df45565e92a1712f5e25d101104319a4c5dcf7f.zip
lldpd: update to v0.7.15 and add support for parsing /etc/openwrt_release
Also drop superseded patches. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45810
Diffstat (limited to 'package/network/services/lldpd/Makefile')
-rw-r--r--package/network/services/lldpd/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index d80840e4cb..69f70221a9 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lldpd
-PKG_VERSION:=0.7.13
-PKG_RELEASE:=2
+PKG_VERSION:=0.7.15
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=13e8be761753eac9a8e12128acba40b4
+PKG_MD5SUM:=46f7ad97fc1d04084ab11b32fc0ed708
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
@@ -92,6 +92,7 @@ CONFIGURE_ARGS += \
,--disable-privsep) \
--with-readline=no \
--with-embedded-libevent=no \
+ --disable-hardening \
$(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
$(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
$(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
@@ -99,7 +100,7 @@ CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
$(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
$(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
- $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+ $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)
$(eval $(call BuildPackage,lldpd))