aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/igmpproxy/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-04 07:19:51 +0000
committerJohn Crispin <john@openwrt.org>2014-06-04 07:19:51 +0000
commit39798dc43b55016312c9f88199915419861a1d2d (patch)
tree8e2a36b62730637f01170f054f4b7cddcc2b029d /package/network/services/igmpproxy/Makefile
parent21b0a8d8a4661261a2f468627186755682a5845f (diff)
downloadupstream-39798dc43b55016312c9f88199915419861a1d2d.tar.gz
upstream-39798dc43b55016312c9f88199915419861a1d2d.tar.bz2
upstream-39798dc43b55016312c9f88199915419861a1d2d.zip
igmpproxy: update init.d script to procd and add a hotplug script
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40997
Diffstat (limited to 'package/network/services/igmpproxy/Makefile')
-rw-r--r--package/network/services/igmpproxy/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/igmpproxy/Makefile b/package/network/services/igmpproxy/Makefile
index 47b995bb51..027fcb99d2 100644
--- a/package/network/services/igmpproxy/Makefile
+++ b/package/network/services/igmpproxy/Makefile
@@ -51,6 +51,8 @@ define Package/igmpproxy/install
$(INSTALL_CONF) ./files/igmpproxy.config $(1)/etc/config/igmpproxy
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/igmpproxy.init $(1)/etc/init.d/igmpproxy
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_BIN) ./files/igmpproxy.hotplug $(1)/etc/hotplug.d/iface/igmpproxy
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
endef