aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/igmpproxy/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-04 07:19:51 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-04 07:19:51 +0000
commit8d9f6f3396da4e546cf6990a2230469d0bab7339 (patch)
treef5fb749dabe29d8aa125a352e3bd92b7be9e122e /package/network/services/igmpproxy/Makefile
parentb52c3cbf9691a654f51d48196985bf1304e6af28 (diff)
downloadupstream-8d9f6f3396da4e546cf6990a2230469d0bab7339.tar.gz
upstream-8d9f6f3396da4e546cf6990a2230469d0bab7339.tar.bz2
upstream-8d9f6f3396da4e546cf6990a2230469d0bab7339.zip
igmpproxy: update init.d script to procd and add a hotplug script
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40997 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/igmpproxy/Makefile')
-rw-r--r--package/network/services/igmpproxy/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/igmpproxy/Makefile b/package/network/services/igmpproxy/Makefile
index 47b995bb51..027fcb99d2 100644
--- a/package/network/services/igmpproxy/Makefile
+++ b/package/network/services/igmpproxy/Makefile
@@ -51,6 +51,8 @@ define Package/igmpproxy/install
$(INSTALL_CONF) ./files/igmpproxy.config $(1)/etc/config/igmpproxy
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/igmpproxy.init $(1)/etc/init.d/igmpproxy
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_BIN) ./files/igmpproxy.hotplug $(1)/etc/hotplug.d/iface/igmpproxy
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
endef