aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-07 13:27:23 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-15 18:46:50 +0100
commit46e875a0b05e431365a15d0eb8a61f68e001a696 (patch)
tree80b42b7105d46c54a89a9d18e857251cec594cd0 /package/network/services/hostapd
parente3c55dbe30c7a4282e651282d98db43419968422 (diff)
downloadupstream-46e875a0b05e431365a15d0eb8a61f68e001a696.tar.gz
upstream-46e875a0b05e431365a15d0eb8a61f68e001a696.tar.bz2
upstream-46e875a0b05e431365a15d0eb8a61f68e001a696.zip
hostapd: refresh ubus patch
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/patches/600-ubus_support.patch54
1 files changed, 18 insertions, 36 deletions
diff --git a/package/network/services/hostapd/patches/600-ubus_support.patch b/package/network/services/hostapd/patches/600-ubus_support.patch
index b63d99a57d..8f14f125d5 100644
--- a/package/network/services/hostapd/patches/600-ubus_support.patch
+++ b/package/network/services/hostapd/patches/600-ubus_support.patch
@@ -1,7 +1,5 @@
-Index: hostapd-2017-08-24-c2d4f2eb/hostapd/Makefile
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/hostapd/Makefile
-+++ hostapd-2017-08-24-c2d4f2eb/hostapd/Makefile
+--- a/hostapd/Makefile
++++ b/hostapd/Makefile
@@ -165,6 +165,11 @@ OBJS += ../src/common/hw_features_common
OBJS += ../src/eapol_auth/eapol_auth_sm.o
@@ -14,10 +12,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/hostapd/Makefile
ifdef CONFIG_CODE_COVERAGE
CFLAGS += -O0 -fprofile-arcs -ftest-coverage
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.h
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/hostapd.h
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.h
+--- a/src/ap/hostapd.h
++++ b/src/ap/hostapd.h
@@ -13,6 +13,7 @@
#include "utils/list.h"
#include "ap_config.h"
@@ -43,10 +39,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.h
enum hostapd_iface_state {
HAPD_IFACE_UNINITIALIZED,
HAPD_IFACE_DISABLED,
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/hostapd.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.c
+--- a/src/ap/hostapd.c
++++ b/src/ap/hostapd.c
@@ -309,6 +309,7 @@ static void hostapd_free_hapd_data(struc
hapd->started = 0;
@@ -88,10 +82,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/hostapd.c
hostapd_interface_deinit(iface);
wpa_printf(MSG_DEBUG, "%s: driver=%p drv_priv=%p -> hapd_deinit",
__func__, driver, drv_priv);
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/ieee802_11.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/ieee802_11.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/ieee802_11.c
+--- a/src/ap/ieee802_11.c
++++ b/src/ap/ieee802_11.c
@@ -1587,7 +1587,8 @@ ieee802_11_set_radius_info(struct hostap
@@ -209,10 +201,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/ieee802_11.c
ret = 1;
break;
case WLAN_FC_STYPE_DISASSOC:
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/beacon.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.c
+--- a/src/ap/beacon.c
++++ b/src/ap/beacon.c
@@ -716,7 +716,7 @@ void sta_track_claim_taxonomy_info(struc
void handle_probe_req(struct hostapd_data *hapd,
@@ -251,10 +241,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.c
/* TODO: verify that supp_rates contains at least one matching rate
* with AP configuration */
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.h
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/beacon.h
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.h
+--- a/src/ap/beacon.h
++++ b/src/ap/beacon.h
@@ -14,7 +14,7 @@ struct ieee80211_mgmt;
void handle_probe_req(struct hostapd_data *hapd,
@@ -264,10 +252,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/beacon.h
int ieee802_11_set_beacon(struct hostapd_data *hapd);
int ieee802_11_set_beacons(struct hostapd_iface *iface);
int ieee802_11_update_beacons(struct hostapd_iface *iface);
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/drv_callbacks.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/drv_callbacks.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/drv_callbacks.c
+--- a/src/ap/drv_callbacks.c
++++ b/src/ap/drv_callbacks.c
@@ -116,6 +116,10 @@ int hostapd_notif_assoc(struct hostapd_d
u16 reason = WLAN_REASON_UNSPECIFIED;
u16 status = WLAN_STATUS_SUCCESS;
@@ -292,10 +278,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/drv_callbacks.c
#ifdef CONFIG_P2P
if (elems.p2p) {
wpabuf_free(sta->p2p_ie);
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/sta_info.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/sta_info.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/sta_info.c
+--- a/src/ap/sta_info.c
++++ b/src/ap/sta_info.c
@@ -404,6 +404,7 @@ void ap_handle_timer(void *eloop_ctx, vo
HOSTAPD_LEVEL_INFO, "deauthenticated due to "
"local deauth request");
@@ -320,10 +304,8 @@ Index: hostapd-2017-08-24-c2d4f2eb/src/ap/sta_info.c
if (hapd->msg_ctx_parent &&
hapd->msg_ctx_parent != hapd->msg_ctx)
-Index: hostapd-2017-08-24-c2d4f2eb/src/ap/wpa_auth_glue.c
-===================================================================
---- hostapd-2017-08-24-c2d4f2eb.orig/src/ap/wpa_auth_glue.c
-+++ hostapd-2017-08-24-c2d4f2eb/src/ap/wpa_auth_glue.c
+--- a/src/ap/wpa_auth_glue.c
++++ b/src/ap/wpa_auth_glue.c
@@ -175,6 +175,7 @@ static void hostapd_wpa_auth_psk_failure
struct hostapd_data *hapd = ctx;
wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,