aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-05-13 16:17:44 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-05-13 17:12:54 +0200
commit1a16cb9c67f0d2c530914aec31c721b75f03a908 (patch)
tree7bb379b72b5d34cfdf950c98a312ec56d62f95e4 /package/network/services/hostapd
parent5e481881d7abd814abbf40a046be90cbaf835e72 (diff)
downloadupstream-1a16cb9c67f0d2c530914aec31c721b75f03a908.tar.gz
upstream-1a16cb9c67f0d2c530914aec31c721b75f03a908.tar.bz2
upstream-1a16cb9c67f0d2c530914aec31c721b75f03a908.zip
mac80211, hostapd: always explicitly set beacon interval
One of the latest mac80211 updates added sanity checks, requiring the beacon intervals of all VIFs of the same radio to match. This often broke AP+11s setups, as these modes use different default intervals, at least in some configurations (observed on ath9k). Instead of relying on driver or hostapd defaults, change the scripts to always explicitly set the beacon interval, defaulting to 100. This also applies the beacon interval to 11s interfaces, which had been forgotten before. VIF-specific beacon_int setting is removed from hostapd.sh. Fixes FS#619. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh5
2 files changed, 3 insertions, 4 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f3aa94b6ea..b7cc6b9c34 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 816dd8cad5..86e9a32e5b 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -76,7 +76,7 @@ hostapd_prepare_device_config() {
local base="${config%%.conf}"
local base_cfg=
- json_get_vars country country_ie beacon_int doth require_mode legacy_rates
+ json_get_vars country country_ie beacon_int:100 doth require_mode legacy_rates
hostapd_set_log_options base_cfg
@@ -121,7 +121,7 @@ hostapd_prepare_device_config() {
[ -n "$rlist" ] && append base_cfg "supported_rates=$rlist" "$N"
[ -n "$brlist" ] && append base_cfg "basic_rates=$brlist" "$N"
- [ -n "$beacon_int" ] && append base_cfg "beacon_int=$beacon_int" "$N"
+ append base_cfg "beacon_int=$beacon_int" "$N"
cat > "$config" <<EOF
driver=$driver
@@ -709,7 +709,6 @@ wpa_supplicant_add_network() {
esac
}
[ -n "$bssid" ] && append network_data "bssid=$bssid" "$N$T"
- [ -n "$beacon_int" ] && append network_data "beacon_int=$beacon_int" "$N$T"
local bssid_blacklist bssid_whitelist
json_get_values bssid_blacklist bssid_blacklist