aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-03-02 13:06:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-03-02 13:06:57 +0000
commit7a4bf5434d3919fafb15cc8a55789e38998b6462 (patch)
tree5330198dc929fc123d8794021c1443ea356adf56 /package/network/services/hostapd
parentd6742f9ca238001ead055d3ccd0c29df6193439e (diff)
downloadupstream-7a4bf5434d3919fafb15cc8a55789e38998b6462.tar.gz
upstream-7a4bf5434d3919fafb15cc8a55789e38998b6462.tar.bz2
upstream-7a4bf5434d3919fafb15cc8a55789e38998b6462.zip
mac80211/hostapd: rework 802.11w driver support selection, do not hardcode drivers in hostapd makefile
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r46903 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48878 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Config.in4
-rw-r--r--package/network/services/hostapd/Makefile2
2 files changed, 5 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 65125a36df..aee2a15fd3 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -46,3 +46,7 @@ config DRIVER_WEXT_SUPPORT
config DRIVER_11N_SUPPORT
bool
default n
+
+config DRIVER_11W_SUPPORT
+ bool
+ default n
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index c16cb11294..8e706dc5a3 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
ifeq ($(LOCAL_VARIANT),full)
- DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
endif
ifneq ($(LOCAL_TYPE),hostapd)