aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/patches/601-ucode_support.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-09-19 11:02:54 +0200
committerFelix Fietkau <nbd@nbd.name>2023-09-19 11:57:18 +0200
commit09b9d732ec76a0cf0c80223f1c0b991139dd4e82 (patch)
treebaf28930520cacf6f6eb90603b9773eed3caff49 /package/network/services/hostapd/patches/601-ucode_support.patch
parent8b385a45a65cb4721e6bb2fbb24ce080417e331f (diff)
downloadupstream-09b9d732ec76a0cf0c80223f1c0b991139dd4e82.tar.gz
upstream-09b9d732ec76a0cf0c80223f1c0b991139dd4e82.tar.bz2
upstream-09b9d732ec76a0cf0c80223f1c0b991139dd4e82.zip
hostapd: use phy name for hostapd interfaces instead of first-bss ifname
Improves reliability in error handling Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit a511480368a03f754aa6ce7887633247a07ea166)
Diffstat (limited to 'package/network/services/hostapd/patches/601-ucode_support.patch')
-rw-r--r--package/network/services/hostapd/patches/601-ucode_support.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/network/services/hostapd/patches/601-ucode_support.patch b/package/network/services/hostapd/patches/601-ucode_support.patch
index c8bbfd43d8..858dc52a98 100644
--- a/package/network/services/hostapd/patches/601-ucode_support.patch
+++ b/package/network/services/hostapd/patches/601-ucode_support.patch
@@ -142,6 +142,16 @@
{
if (!hapd)
return;
+@@ -3491,7 +3495,8 @@ int hostapd_remove_iface(struct hapd_int
+ hapd_iface = interfaces->iface[i];
+ if (hapd_iface == NULL)
+ return -1;
+- if (!os_strcmp(hapd_iface->conf->bss[0]->iface, buf)) {
++ if (!os_strcmp(hapd_iface->phy, buf) ||
++ !os_strcmp(hapd_iface->conf->bss[0]->iface, buf)) {
+ wpa_printf(MSG_INFO, "Remove interface '%s'", buf);
+ hapd_iface->driver_ap_teardown =
+ !!(hapd_iface->drv_flags &
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
@@ -195,8 +195,20 @@ endif