aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-25 16:48:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-25 16:48:45 +0000
commit3c9fcd2526e8a25a618851453ceb6a63e83c53b3 (patch)
treeb62342b3ba0a466b7104ec1e2d76352c122223f2 /package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
parent78bd998e49120d309ddfce88de4b2df42bee2646 (diff)
downloadupstream-3c9fcd2526e8a25a618851453ceb6a63e83c53b3.tar.gz
upstream-3c9fcd2526e8a25a618851453ceb6a63e83c53b3.tar.bz2
upstream-3c9fcd2526e8a25a618851453ceb6a63e83c53b3.zip
hostapd: update to 2014-10-25
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43059
Diffstat (limited to 'package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch')
-rw-r--r--package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch b/package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
index 8c4e9bdcc4..ef4f961bfc 100644
--- a/package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
+++ b/package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
@@ -1,6 +1,6 @@
--- a/hostapd/Makefile
+++ b/hostapd/Makefile
-@@ -163,6 +163,9 @@ endif
+@@ -164,6 +164,9 @@ endif
ifdef CONFIG_NO_CTRL_IFACE
CFLAGS += -DCONFIG_NO_CTRL_IFACE
else
@@ -12,7 +12,7 @@
endif
--- a/hostapd/ctrl_iface.c
+++ b/hostapd/ctrl_iface.c
-@@ -1447,6 +1447,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -1653,6 +1653,7 @@ static void hostapd_ctrl_iface_receive(i
reply_size);
} else if (os_strcmp(buf, "STATUS-DRIVER") == 0) {
reply_len = hostapd_drv_status(hapd, reply, reply_size);
@@ -20,7 +20,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = ieee802_11_get_mib(hapd, reply, reply_size);
if (reply_len >= 0) {
-@@ -1488,6 +1489,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -1694,6 +1695,7 @@ static void hostapd_ctrl_iface_receive(i
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = hostapd_ctrl_iface_sta_next(hapd, buf + 9, reply,
reply_size);
@@ -30,7 +30,7 @@
reply_len = -1;
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
-@@ -805,6 +805,9 @@ ifdef CONFIG_WNM
+@@ -809,6 +809,9 @@ ifdef CONFIG_WNM
OBJS += ../src/ap/wnm_ap.o
endif
ifdef CONFIG_CTRL_IFACE
@@ -42,7 +42,7 @@
--- a/wpa_supplicant/ctrl_iface.c
+++ b/wpa_supplicant/ctrl_iface.c
-@@ -1602,7 +1602,7 @@ static int wpa_supplicant_ctrl_iface_sta
+@@ -1628,7 +1628,7 @@ static int wpa_supplicant_ctrl_iface_sta
pos += ret;
}
@@ -51,7 +51,7 @@
if (wpa_s->ap_iface) {
pos += ap_ctrl_iface_wpa_get_status(wpa_s, pos,
end - pos,
-@@ -6243,6 +6243,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -6720,6 +6720,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = -1;
} else if (os_strncmp(buf, "NOTE ", 5) == 0) {
wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -59,7 +59,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
if (reply_len >= 0) {
-@@ -6254,6 +6255,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -6731,6 +6732,7 @@ char * wpa_supplicant_ctrl_iface_process
else
reply_len += res;
}
@@ -67,7 +67,7 @@
} else if (os_strncmp(buf, "STATUS", 6) == 0) {
reply_len = wpa_supplicant_ctrl_iface_status(
wpa_s, buf + 6, reply, reply_size);
-@@ -6661,6 +6663,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -7140,6 +7142,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = wpa_supplicant_ctrl_iface_bss(
wpa_s, buf + 4, reply, reply_size);
#ifdef CONFIG_AP
@@ -75,7 +75,7 @@
} else if (os_strcmp(buf, "STA-FIRST") == 0) {
reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
} else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -6669,12 +6672,15 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -7148,12 +7151,15 @@ char * wpa_supplicant_ctrl_iface_process
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
reply_size);
@@ -109,14 +109,14 @@
#ifdef CONFIG_P2P_MANAGER
static int p2p_manager_disconnect(struct hostapd_data *hapd, u16 stype,
-@@ -526,3 +528,4 @@ int hostapd_parse_csa_settings(const cha
+@@ -527,3 +529,4 @@ int hostapd_parse_csa_settings(const cha
return 0;
}
+
--- a/src/ap/ieee802_1x.c
+++ b/src/ap/ieee802_1x.c
-@@ -2124,6 +2124,7 @@ static const char * bool_txt(Boolean boo
+@@ -2237,6 +2237,7 @@ static const char * bool_txt(Boolean boo
return bool_val ? "TRUE" : "FALSE";
}
@@ -124,7 +124,7 @@
int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
{
-@@ -2291,6 +2292,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2404,6 +2405,7 @@ int ieee802_1x_get_mib_sta(struct hostap
return len;
}
@@ -134,7 +134,7 @@
struct sta_info *sta, int success,
--- a/src/ap/wpa_auth.c
+++ b/src/ap/wpa_auth.c
-@@ -2832,6 +2832,7 @@ static const char * wpa_bool_txt(int boo
+@@ -2835,6 +2835,7 @@ static const char * wpa_bool_txt(int boo
return bool ? "TRUE" : "FALSE";
}
@@ -142,7 +142,7 @@
#define RSN_SUITE "%02x-%02x-%02x-%d"
#define RSN_SUITE_ARG(s) \
-@@ -2976,7 +2977,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
+@@ -2979,7 +2980,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
return len;
}
@@ -153,7 +153,7 @@
{
--- a/src/rsn_supp/wpa.c
+++ b/src/rsn_supp/wpa.c
-@@ -1911,6 +1911,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
+@@ -1928,6 +1928,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
}
@@ -162,7 +162,7 @@
#define RSN_SUITE "%02x-%02x-%02x-%d"
#define RSN_SUITE_ARG(s) \
((s) >> 24) & 0xff, ((s) >> 16) & 0xff, ((s) >> 8) & 0xff, (s) & 0xff
-@@ -1994,6 +1996,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
+@@ -2011,6 +2013,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
return (int) len;
}
@@ -172,7 +172,7 @@
--- a/wpa_supplicant/ap.c
+++ b/wpa_supplicant/ap.c
-@@ -984,7 +984,7 @@ int wpas_ap_wps_nfc_report_handover(stru
+@@ -975,7 +975,7 @@ int wpas_ap_wps_nfc_report_handover(stru
#endif /* CONFIG_WPS */