aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-12-10 11:30:40 +0100
committerFelix Fietkau <nbd@nbd.name>2021-12-10 11:33:49 +0100
commitea49690ff47d14ee096d7c1368cff03f1cce1d76 (patch)
treee23de09f8995aea2692a1d25d6c67d6c8caab026 /package/network/services/hostapd/Makefile
parentbaba2fdaa60c2f2426ec09eaacd6dfb7cec3fd2c (diff)
downloadupstream-ea49690ff47d14ee096d7c1368cff03f1cce1d76.tar.gz
upstream-ea49690ff47d14ee096d7c1368cff03f1cce1d76.tar.bz2
upstream-ea49690ff47d14ee096d7c1368cff03f1cce1d76.zip
hostapd: add support for specifying the FILS DHCP server
The 'fils_dhcp' option can be set to '*' in order to autodetect the DHCP server For proto=dhcp networks, the discovered dhcp server will be used For all other networks, udhcpc is called to discover the address Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 12e200be3e..7e4056bb18 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -601,6 +601,7 @@ endef
define Package/hostapd-common/install
$(INSTALL_DIR) $(1)/etc/capabilities $(1)/etc/rc.button $(1)/etc/hotplug.d/ieee80211 $(1)/etc/init.d $(1)/lib/netifd $(1)/usr/share/acl.d
+ $(INSTALL_BIN) ./files/dhcp-get-server.sh $(1)/lib/netifd/dhcp-get-server.sh
$(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/netifd/hostapd.sh
$(INSTALL_BIN) ./files/wpad.init $(1)/etc/init.d/wpad
$(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps