aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-04-06 23:58:40 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-04-14 00:22:21 +0100
commitf37d6342367b4f8393f9693edd96b12dfa016399 (patch)
tree39814f5b920a29263d3d25bd9991a4e906297b8b /package/network/services/hostapd/Makefile
parent35f208da3c13cc16227f229f8aea14c4f0a06928 (diff)
downloadupstream-f37d6342367b4f8393f9693edd96b12dfa016399.tar.gz
upstream-f37d6342367b4f8393f9693edd96b12dfa016399.tar.bz2
upstream-f37d6342367b4f8393f9693edd96b12dfa016399.zip
hostapd: reduce to a single instance per service
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b7fe1d8018..aa57d2121a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -526,9 +526,9 @@ define Install/supplicant
endef
define Package/hostapd-common/install
- $(INSTALL_DIR) $(1)/lib/netifd $(1)/etc/rc.button $(1)/etc/hotplug.d/ieee80211
+ $(INSTALL_DIR) $(1)/lib/netifd $(1)/etc/rc.button $(1)/etc/hotplug.d/ieee80211 $(1)/etc/init.d
$(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/netifd/hostapd.sh
- $(INSTALL_BIN) ./files/hostapd.hotplug $(1)/etc/hotplug.d/ieee80211/20-hostapd
+ $(INSTALL_BIN) ./files/wpad.init $(1)/etc/init.d/wpad
$(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps
endef