aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-09-01 21:31:20 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-09-01 21:37:35 +0100
commit80a194b1000fcbfbec056c545f65c7e93b5b0f0d (patch)
tree4efec978f8ee3b8f0fa0c034a7fd9641af47eb55 /package/network/services/hostapd/Makefile
parent7f0cb91d713245f4c4534ab6214ce023245d16b1 (diff)
downloadupstream-80a194b1000fcbfbec056c545f65c7e93b5b0f0d.tar.gz
upstream-80a194b1000fcbfbec056c545f65c7e93b5b0f0d.tar.bz2
upstream-80a194b1000fcbfbec056c545f65c7e93b5b0f0d.zip
hostapd: add hs20 variant
Add hostapd variant compiled with support for Hotspot 2.0 AP features. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 3aa17b4d3a..5e56a43e9a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -68,6 +68,9 @@ CONFIG_VARIANT:=$(LOCAL_VARIANT)
ifeq ($(LOCAL_VARIANT),mesh)
CONFIG_VARIANT:=full
endif
+ifeq ($(LOCAL_VARIANT),hs20)
+ CONFIG_VARIANT:=full
+endif
include $(INCLUDE_DIR)/package.mk
@@ -108,6 +111,10 @@ ifeq ($(SSL_VARIANT),openssl)
ifeq ($(LOCAL_VARIANT),full)
DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
endif
+ ifeq ($(LOCAL_VARIANT),hs20)
+ DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y CONFIG_DPP=y CONFIG_HS20=y CONFIG_INTERWORKING=y
+ endif
+
endif
ifeq ($(SSL_VARIANT),wolfssl)
@@ -168,6 +175,15 @@ endef
Package/hostapd-openssl/description = $(Package/hostapd/description)
+define Package/hostapd-hs20
+$(call Package/hostapd/Default,$(1))
+ TITLE+= (OpenSSL with Hotspot 2.0)
+ VARIANT:=hs20-openssl
+ DEPENDS+=+libopenssl
+endef
+
+Package/hostapd-hs20/description = $(Package/hostapd/description)
+
define Package/hostapd-wolfssl
$(call Package/hostapd/Default,$(1))
TITLE+= (wolfSSL full)
@@ -453,7 +469,9 @@ define Build/Configure
$(if $(wildcard ./files/hostapd-$(CONFIG_VARIANT).config), \
$(CP) ./files/hostapd-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config \
)
- $(CP) ./files/wpa_supplicant-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/wpa_supplicant/.config
+ $(if $(wildcard ./files/wpa_supplicant-$(CONFIG_VARIANT).config), \
+ $(CP) ./files/wpa_supplicant-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/wpa_supplicant/.config
+ )
endef
TARGET_CPPFLAGS := \
@@ -567,6 +585,7 @@ define Package/hostapd/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
endef
Package/hostapd-basic/install = $(Package/hostapd/install)
+Package/hostapd-hs20/install = $(Package/hostapd/install)
Package/hostapd-mini/install = $(Package/hostapd/install)
Package/hostapd-openssl/install = $(Package/hostapd/install)
Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -635,6 +654,7 @@ endif
$(eval $(call BuildPackage,hostapd))
$(eval $(call BuildPackage,hostapd-basic))
+$(eval $(call BuildPackage,hostapd-hs20))
$(eval $(call BuildPackage,hostapd-mini))
$(eval $(call BuildPackage,hostapd-openssl))
$(eval $(call BuildPackage,hostapd-wolfssl))