aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorDobroslaw Kijowski <dobo90@gmail.com>2020-11-16 20:32:38 +0100
committerDavid Bauer <mail@david-bauer.net>2020-11-17 17:06:16 +0100
commitedb93eda161218af49393e2f2c68b87d5538a658 (patch)
tree741559d1753d42082f3ea568658e927c3ef55753 /package/network/services/hostapd/Makefile
parent03cdeb5f97f82d4be34e3545efa47c0b9aa0fc05 (diff)
downloadupstream-edb93eda161218af49393e2f2c68b87d5538a658.tar.gz
upstream-edb93eda161218af49393e2f2c68b87d5538a658.tar.bz2
upstream-edb93eda161218af49393e2f2c68b87d5538a658.zip
hostapd: add support for static airtime policy configuration
* Add support for passing airtime_sta_weight into hostapd configuration. * Since that commit it is possible to configure station weights. Set higher value for larger airtime share, lower for smaller share. I have tested this functionality by modyfing /etc/config/wireless to: config wifi-device 'radio0' ... option airtime_mode '1' config wifi-iface 'default_radio0' ... list airtime_sta_weight '01:02:03:04:05:06 1024' Now, when the station associates with the access point it has been assigned a higher weight value. root@OpenWrt:~# cat /sys/kernel/debug/ieee80211/phy0/netdev\:wlan0/stations/01\:02\:03\:04\:05\:06/airtime RX: 12656 us TX: 10617 us Weight: 1024 Deficit: VO: -2075 us VI: 256 us BE: -206 us BK: 256 us [MAC address has been changed into a dummy one.] Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 9a8a74ced9..e25cd20a2a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git