aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-09-30 03:35:50 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-10-07 05:49:22 +0300
commitc0882035353238b061369fcff4bb1e248409e71a (patch)
tree19878a13d5ade94296bdd8630ae2841a00abc39a /package/network/services/hostapd/Makefile
parent2f78034c3ef71bdeb1f2955aa8844b1d1ec70d3a (diff)
downloadupstream-c0882035353238b061369fcff4bb1e248409e71a.tar.gz
upstream-c0882035353238b061369fcff4bb1e248409e71a.tar.bz2
upstream-c0882035353238b061369fcff4bb1e248409e71a.zip
hostapd: escape double quoutes in wpad CFLAGS
A recent commit in hostapd added a build option to specify the default TLS ciphers. This build option is passed via CFLAGS. Due to the way CFLAGS are handled when building wpad, the compiler tries to recursively expand TLS_DEFAULT_CIPHERS, resulting in the following error: ../src/crypto/tls_openssl.c: In function 'tls_init': <command-line>:0:21: error: 'DEFAULT' undeclared (first use in this function) ../src/crypto/tls_openssl.c:1028:13: note: in expansion of macro 'TLS_DEFAULT_CIPHERS' ciphers = TLS_DEFAULT_CIPHERS; ^ Escape double quotes in the .cflags file to avoid this. Fixes: 2f78034c3ef ("hostapd: update to version 2017-08-24") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 2558f2da0b..344896ca62 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -299,6 +299,7 @@ define Build/Compile/wpad
$(call Build/RunMake,wpa_supplicant,-s MULTICALL=1 dump_cflags) | \
sed -e 's,-n ,,g' -e 's^$(TARGET_CFLAGS)^^' \
` > $(PKG_BUILD_DIR)/.cflags
+ sed -i 's/"/\\"/g' $(PKG_BUILD_DIR)/.cflags
+$(call Build/RunMake,hostapd, \
CFLAGS="$$$$(cat $(PKG_BUILD_DIR)/.cflags)" \
MULTICALL=1 \