aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-10-05 23:01:33 +0200
committerFelix Fietkau <nbd@nbd.name>2016-10-05 23:02:13 +0200
commit73c87a3cad3c77d581e46ef9707d175a0651351f (patch)
treec3e1e1cb36a86ea3099aab00ec2f74d81f5e70a4 /package/network/services/hostapd/Makefile
parent116adaa3a4dc6c5d232bf7a9ea08d82afcfbb87e (diff)
downloadupstream-73c87a3cad3c77d581e46ef9707d175a0651351f.tar.gz
upstream-73c87a3cad3c77d581e46ef9707d175a0651351f.tar.bz2
upstream-73c87a3cad3c77d581e46ef9707d175a0651351f.zip
hostapd: make -mesh and -p2p variants depend on the cfg80211 symbol
Avoids build failures when the nl80211 driver is disabled Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b4684b691a..d53f436ff2 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -175,7 +175,7 @@ endef
define Package/wpad-mesh
$(call Package/wpad/Default)
TITLE+= (with 802.11s mesh and SAE support)
- DEPENDS:=$(DRV_DEPENDS) +libubus +PACKAGE_wpad-mesh:libopenssl @(!TARGET_uml||BROKEN)
+ DEPENDS:=$(DRV_DEPENDS) +libubus +PACKAGE_wpad-mesh:libopenssl @PACKAGE_kmod-cfg80211 @(!TARGET_uml||BROKEN)
VARIANT:=wpad-mesh
endef
@@ -204,7 +204,7 @@ endef
define Package/wpa-supplicant-p2p
$(Package/wpa-supplicant)
TITLE:=WPA Supplicant (with Wi-Fi P2P support)
- DEPENDS:=$(DRV_DEPENDS)
+ DEPENDS:=$(DRV_DEPENDS) @PACKAGE_kmod-cfg80211
CONFLICTS:=wpad wpad-mini wpad-mesh
VARIANT:=supplicant-p2p
endef
@@ -216,7 +216,7 @@ endef
define Package/wpa-supplicant-mesh
$(Package/wpa-supplicant)
TITLE:=WPA Supplicant (with 802.11s and SAE)
- DEPENDS:=$(DRV_DEPENDS) @(!TARGET_uml||BROKEN)
+ DEPENDS:=$(DRV_DEPENDS) @PACKAGE_kmod-cfg80211 @(!TARGET_uml||BROKEN)
CONFLICTS:=wpad wpad-mesh wpad-mesh
VARIANT:=supplicant-mesh
endef