aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-05-31 15:18:12 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:06:02 +0100
commit5826efd18ca970462cefa7f82edcd671493d32fb (patch)
treed60f1172a65ef99324f28d64da80add103c6e008 /package/network/services/hostapd/Makefile
parent000a3fef0ad9c0f0bcea0a9981c7700d66a97ab8 (diff)
downloadupstream-5826efd18ca970462cefa7f82edcd671493d32fb.tar.gz
upstream-5826efd18ca970462cefa7f82edcd671493d32fb.tar.bz2
upstream-5826efd18ca970462cefa7f82edcd671493d32fb.zip
hostapd: properly build hostapd-only SSL variants
Make sure hostapd-openssl is actually build against OpenSSL, same for wolfSSL. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (backported from 987900f2de76e6d292e55aa068c39b03f79c8812)
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 56d064c73b..5edc513e0e 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
@@ -107,18 +107,18 @@ ifeq ($(LOCAL_VARIANT),full)
DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
endif
-ifneq ($(LOCAL_TYPE),hostapd)
- ifeq ($(LOCAL_VARIANT),full)
- ifeq ($(SSL_VARIANT),openssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=openssl
- TARGET_LDFLAGS += -lcrypto -lssl
- endif
- ifeq ($(SSL_VARIANT),wolfssl)
- DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_WPS_NFC=1
- TARGET_LDFLAGS += -lwolfssl
- endif
+ifeq ($(LOCAL_VARIANT),full)
+ ifeq ($(SSL_VARIANT),openssl)
+ DRIVER_MAKEOPTS += CONFIG_TLS=openssl
+ TARGET_LDFLAGS += -lcrypto -lssl
+ endif
+ ifeq ($(SSL_VARIANT),wolfssl)
+ DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_WPS_NFC=1
+ TARGET_LDFLAGS += -lwolfssl
endif
+endif
+ifneq ($(LOCAL_TYPE),hostapd)
ifeq ($(LOCAL_VARIANT),mesh)
ifeq ($(SSL_VARIANT),openssl)
DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_AP=y CONFIG_SAE=y CONFIG_MESH=y