aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:18 +0000
commit3adce75a67ba10fc151fe49d4dad3f04fe265135 (patch)
treebdfdf8989304a7d509d32a278773c3b58be905a1 /package/network/services/hostapd/Makefile
parent3d6a411f1408f364e768b9f0aca9ad3cf587f912 (diff)
downloadupstream-3adce75a67ba10fc151fe49d4dad3f04fe265135.tar.gz
upstream-3adce75a67ba10fc151fe49d4dad3f04fe265135.tar.bz2
upstream-3adce75a67ba10fc151fe49d4dad3f04fe265135.zip
hostapd: work around unconditional libopenssl build dependency
As the OpenWrt build system only resolves build dependencies per directory, all hostapd variants were causing libopenssl to be downloaded and built, not only wpad-mesh. Fix this by applying the same workaround as in ustream-ssl. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 46851
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index c16cb11294..c39b6b410d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -177,7 +177,7 @@ endef
define Package/wpad-mesh
$(call Package/wpad/Default)
TITLE+= (with 802.11s mesh and SAE support)
- DEPENDS:=$(DRV_DEPENDS) +libubus +libopenssl +@CONFIG_WPA_SUPPLICANT_OPENSSL @(!TARGET_uml||BROKEN)
+ DEPENDS:=$(DRV_DEPENDS) +libubus +PACKAGE_wpad-mesh:libopenssl +@CONFIG_WPA_SUPPLICANT_OPENSSL @(!TARGET_uml||BROKEN)
CONFLICTS:=@WPA_SUPPLICANT_INTERNAL
VARIANT:=wpad-mesh
endef