aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
commit31876c193aaa8ddbe6c5758aee5754aee257fc44 (patch)
tree87fb9c06e3d6aacd00df5f6e5f0db88418ff346e /package/network/services/hostapd/Makefile
parent3ebdd3b330f31e3e98629e534a928af84136de1f (diff)
downloadupstream-31876c193aaa8ddbe6c5758aee5754aee257fc44.tar.gz
upstream-31876c193aaa8ddbe6c5758aee5754aee257fc44.tar.bz2
upstream-31876c193aaa8ddbe6c5758aee5754aee257fc44.zip
hostapd: fix build errors on supplicant-only builds
SVN-Revision: 36085
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 0c44a8b08d..7024844d10 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+ TARGET_LDFLAGS += -lubox -lubus
+endif
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny