aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-19 21:58:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-19 21:58:48 +0000
commit239b3c09c9ff902e21a761ba453d4ae6293832ad (patch)
treee9eaeaa75eb876a8614b4d466750656326777e54 /package/network/services/hostapd/Makefile
parent00776714accb008a4ddf2221be02abb332cf9ce5 (diff)
downloadupstream-239b3c09c9ff902e21a761ba453d4ae6293832ad.tar.gz
upstream-239b3c09c9ff902e21a761ba453d4ae6293832ad.tar.bz2
upstream-239b3c09c9ff902e21a761ba453d4ae6293832ad.zip
hostapd: add a package for eapol_test
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40782
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 80e00823fe..9751af6e7f 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -225,6 +225,15 @@ define Package/hostapd-common-old
CATEGORY:=Network
endef
+define Package/eapol-test
+ TITLE:=802.1x authentication test utility
+ SECTION:=net
+ CATEGORY:=Network
+ VARIANT:=supplicant-full
+ DEPENDS:=$(DRV_DEPENDS)
+endef
+
+
ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
define Build/Configure/rebuild
$(FIND) $(PKG_BUILD_DIR) -name \*.o -or -name \*.a | $(XARGS) rm -f
@@ -309,8 +318,15 @@ define Build/Compile/supplicant
)
endef
+define Build/Compile/supplicant-full
+ $(call Build/RunMake,wpa_supplicant, \
+ eapol_test \
+ )
+endef
+
define Build/Compile
$(Build/Compile/$(LOCAL_TYPE))
+ $(Build/Compile/$(BUILD_VARIANT))
endef
define Install/hostapd
@@ -369,6 +385,13 @@ ifneq ($(LOCAL_TYPE),hostapd)
endef
endif
+ifeq ($(BUILD_VARIANT),supplicant-full)
+ define Package/eapol-test/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/wpa_supplicant/eapol_test $(1)/usr/sbin/
+ endef
+endif
+
$(eval $(call BuildPackage,hostapd))
$(eval $(call BuildPackage,hostapd-mini))
$(eval $(call BuildPackage,wpad))
@@ -380,3 +403,4 @@ $(eval $(call BuildPackage,wpa-cli))
$(eval $(call BuildPackage,hostapd-utils))
$(eval $(call BuildPackage,hostapd-common))
$(eval $(call BuildPackage,hostapd-common-old))
+$(eval $(call BuildPackage,eapol-test))