aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-10 13:48:17 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-10 14:26:35 +0200
commit6dac92a42e052f89971762173daabb7fd84742ef (patch)
treec9c6de6965f57d1e19f2370b487621ef8f9d438a /package/network/services/hostapd/Makefile
parent9b965d3b71e526ae8aeb345510bc1389e567e463 (diff)
downloadupstream-6dac92a42e052f89971762173daabb7fd84742ef.tar.gz
upstream-6dac92a42e052f89971762173daabb7fd84742ef.tar.bz2
upstream-6dac92a42e052f89971762173daabb7fd84742ef.zip
hostapd: build with LTO enabled (using jobserver for parallel build)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 5edc513e0e..cf0b005219 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -457,8 +457,8 @@ TARGET_CPPFLAGS := \
-D_GNU_SOURCE \
$(if $(CONFIG_WPA_MSG_MIN_PRIORITY),-DCONFIG_MSG_MIN_PRIORITY=$(CONFIG_WPA_MSG_MIN_PRIORITY))
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto=jobserver -fuse-linker-plugin
ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
TARGET_LDFLAGS += -lubox -lubus
endif
@@ -474,6 +474,7 @@ define Build/RunMake
$(DRIVER_MAKEOPTS) \
LIBS="$(TARGET_LDFLAGS)" \
LIBS_c="$(TARGET_LDFLAGS_C)" \
+ AR="$(TARGET_CROSS)gcc-ar" \
BCHECK= \
$(2)
endef
@@ -495,7 +496,7 @@ define Build/Compile/wpad
MULTICALL=1 \
wpa_cli wpa_supplicant_multi.a \
)
- $(TARGET_CC) -o $(PKG_BUILD_DIR)/wpad \
+ +export MAKEFLAGS="$(MAKE_JOBSERVER)"; $(TARGET_CC) -o $(PKG_BUILD_DIR)/wpad \
$(TARGET_CFLAGS) \
./files/multicall.c \
$(PKG_BUILD_DIR)/hostapd/hostapd_multi.a \