aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
commitd482f42efbc11314a92898eae9964bbdac7e7db8 (patch)
tree9b7f0c29f028bbe1b11b671fe2c83e04a03f22a3 /package/network/services/hostapd/Makefile
parent72786daa1bb30f0bcb2e0ba66e6c922ddad02c59 (diff)
downloadupstream-d482f42efbc11314a92898eae9964bbdac7e7db8.tar.gz
upstream-d482f42efbc11314a92898eae9964bbdac7e7db8.tar.bz2
upstream-d482f42efbc11314a92898eae9964bbdac7e7db8.zip
hostapd: fix build errors on supplicant-only builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 0c44a8b08d..7024844d10 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+ TARGET_LDFLAGS += -lubox -lubus
+endif
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny