aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:25 +0000
committerJohn Crispin <blogic@openwrt.org>2013-03-13 18:11:25 +0000
commitb715f860d7712b66a5a353026235cccc68a38c46 (patch)
tree461516cee89505b648d0c34f1b4523ce8ccee396 /package/network/services/hostapd/Makefile
parent47d1577ffb1727e63a27c50a29d65cbea5625935 (diff)
downloadupstream-b715f860d7712b66a5a353026235cccc68a38c46.tar.gz
upstream-b715f860d7712b66a5a353026235cccc68a38c46.tar.bz2
upstream-b715f860d7712b66a5a353026235cccc68a38c46.zip
[hostapd] use new button scheme
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36004 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 80845bf06b..16db2d8e23 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -303,6 +303,11 @@ ifneq ($(LOCAL_TYPE),supplicant)
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
$(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+ $(if $(CONFIG_PROCD_INIT),
+ $(INSTALL_DIR) $(1)/etc/rc.button/
+ $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
+ $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+ )
endef
endif