aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dropbear
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-29 17:10:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-29 17:10:52 +0000
commita273f66de752c8e0c2ecb77c906208ae80f9a7ac (patch)
treea45a32405acda1fcbd9b3ce5327d53e42cf9ff6e /package/network/services/dropbear
parent31c24e7253ae989e3e134db4194c0e9fdf2da965 (diff)
downloadupstream-a273f66de752c8e0c2ecb77c906208ae80f9a7ac.tar.gz
upstream-a273f66de752c8e0c2ecb77c906208ae80f9a7ac.tar.bz2
upstream-a273f66de752c8e0c2ecb77c906208ae80f9a7ac.zip
dropbear: move options.h editing to Build/Configure
fixes incremental build with change to CONFIG_DROPBEAR_ECC drop --with-shared which is unknown to configure Patch by Catalin Patulea <cat@vv.carleton.ca> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40300 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/dropbear')
-rw-r--r--package/network/services/dropbear/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 692199e8aa..b2bd8cc605 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -59,7 +59,6 @@ define Package/dropbearconvert
endef
CONFIGURE_ARGS += \
- --with-shared \
--disable-pam \
--enable-openpty \
--enable-syslog \
@@ -78,8 +77,9 @@ CONFIGURE_ARGS += \
TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-define Build/Prepare
- $(call Build/Prepare/Default)
+define Build/Configure
+ $(Build/Configure/Default)
+
# Enforce that all replacements are made, otherwise options.h has changed
# format and this logic is broken.
for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH DROPBEAR_CURVE25519; do \